• Site mis à jour le 22 mars 2019

Installation JCE 2.6.1

  • cdalphin
  • Portrait de cdalphin Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 2 ans 3 mois - il y a 2 ans 3 mois #11414 par cdalphin
Installation JCE 2.6.1 a été créé par cdalphin
Bonjour,

Je viens d'installer Joomla 3.6.4 chez l'hébergeur STRATO et tout s'est passé correctement.
J'ai installé un template et une galerie sans problème.
Par contre, j'ai un problème avec l'installation de JCE 2.6.1
Le serveur est en PHP 5.6
le site est dans un sous-répertoire new-site à la racine de l'hébergement pour test.
Toutes les installations sont réalisées par transfert du package à partir de mon PC.
Suite à des essais infructueux, j'ai appliqué vos conseils indiqués dans un topic de ce forum.
La couche FTP de Joomla est activée avec les paramètres ad-hoc
Le répertoire racine indiqué dans la configuration est /new-site
Les répertoires cache, logs et tmp sont en 777

Cela ne fonctionne toujours pas et j'ai les messages d'erreur ci-dessous:
Alerte
JFTP: :write : mauvaise réponse
Le chemin d'installation n'existe pas
Installation d'un paquet : il y a eu une erreur en installant l'extension Installer

Erreur
Unable to write entry
Paquet : erreur à l'installation

Avec la couche FTP désactivée les messages d'erreur sont les suivants:
Alerte
JFolder::create: Impossible de créer le répertoirePath: /mnt/web014/d0/50/51965950/htdocs/new-site/tmp/install_584e847f796d2/packages/install_584e847fb0315/administrator/components/com_jce/sql
Le chemin d'installation n'existe pas
Installation d'un paquet : il y a eu une erreur en installant l'extension Installer

Erreur
Unable to write entry
Paquet : erreur à l'installation

Il y a clairement un problème d'écriture pour l'installateur du pack.
Tous les répertoires sont 755 et les fichiers en 644.

Voici les messages d'erreurs lors de l'installation du composant com_jce_2531_fr-en.zip avec couche FTP activée.

Alerte
JFTP: :write : mauvaise réponse
Erreur

Unable to write entry
Impossible de trouver un pack d'installation


Une idée?
Claude
Dernière édition: il y a 2 ans 3 mois par mihaly. Raison: Ajout icône Réglé

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 3 mois #11415 par mihaly
Réponse de mihaly sur le sujet Installation JCE 2.6.1
Bonjour Claude,
Au vu des messages, et d'autant plus parce que c'est pareil avec JCE 2.5.31, je pense que cela n'est pas propre à JCE, même si le template et la galerie ont pu être installée.
Déjà il faut savoir que si vous avez pu installer un template ou une galerie, alors cela signifie qu'il n'est pas nécessaire d'activer la couche FTP.
Les messages d'erreur parlent de problème de chemin d'installation qui n'existe pas et d'impossibilité de créer un répertoire. Je pense donc que soit il y a un problème avec les chemins logs et tmp, soit que le temps d'exécution n'est pas assez long pour faire l'installation.
Essayez de décompresser le pack 2.6.1 et testez l'installation du composant et des plugins indépendamment.
Si cela ne fonctionne toujours pas, je vous propose de me faire un compte provisoire SuperUtilisateur ou de me communiquez les accès de votre compte que je puisse aller voir de l'intérieur, vous pouvez les envoyer par le formulaire de ce site ou à l'adresse info @ sarki.ch

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

  • cdalphin
  • Portrait de cdalphin Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 2 ans 3 mois #11420 par cdalphin
Réponse de cdalphin sur le sujet Installation JCE 2.6.1
Bonjour Mihaly,

Merci pour cette réponse rapide.
Dans tous mes essais, il me semble avoir essayé d'installer les éléments du pack après décompression.
Les plugins s'étaient installés mais pas le composant.
Votre suggestion d'un temps d'exécution trop long est à soupçonner d'autant que cela s'est produit avec le composant de la version 2.5.31.
J'essaie de nouveau une installation avec les éléments décompressés du pack et je vous tiens au courant.
Je vous tiens au courant et si le problème perdure je vous enverrai les éléments d'un compte Super Utilisateur

Connexion ou Créer un compte pour participer à la conversation.

  • cdalphin
  • Portrait de cdalphin Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 2 ans 3 mois - il y a 2 ans 3 mois #11421 par cdalphin
Réponse de cdalphin sur le sujet Installation JCE 2.6.1
J'ai oublié.
Les chemins tmp et logs sont corrects dans le fichier configuration.php.
j e l'ai vérifié avec un fichier whoami.php avec la commande PHP.
Dernière édition: il y a 2 ans 3 mois par cdalphin.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 3 mois #11423 par mihaly
Réponse de mihaly sur le sujet Installation JCE 2.6.1
Si les plugins s'étaient installés mais pas le composant, alors c'est sans doute le temps d'execution qui est un peu court, d'autant que tu as eu cela également avec le composant de la version 2.5.31
Il te faudrait donc décompresser le composant sur ton ordi dans un dossier que tu envoies dans le dossier "tmp" de ton Joomla, puis ensuite déclarer le chemin de ce dossier dans l'installeur de Joomla sous l'onglet "Installer à partir d'un répertoire". En principe en évitant le temps de décompression cela passe.

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

  • cdalphin
  • Portrait de cdalphin Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 2 ans 3 mois #11425 par cdalphin
Réponse de cdalphin sur le sujet Installation JCE 2.6.1
J'ai fait comme suggéré.
IL y a toujours des problèmes d'écriture.
Tout se passe comme si les scripts ne pouvaient écrire dans les répertoires.

Alerte
JFTP: :mkdir : mauvaise réponse
JFTP: :chmod : mauvaise réponse
Composant Installer : impossible de créer le répertoire : /mnt/web014/d0/50/51965950/htdocs/new-site/components/com_jce.
Erreur

Message après essai d'installation du package plg_editors_jce.zip non décompressé

Alerte
JFTP: :store : mauvaise réponse
Attention: Impossible de déplacer le fichier : /mnt/shared/tmp/phpixaqtd vers /new-site/tmp/plg_editors_jce.zip
JFTP: :mkdir : mauvaise réponse
JFTP: :chmod : mauvaise réponse
Erreur
Unable to create destination
Impossible de trouver un pack d'installation
Composant : erreur à l'installation

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.152 secondes
Propulsé par Kunena

Rechercher