• Site mis à jour le 22 mars 2019

[réglé] Liens en frontend

Plus d'informations
il y a 9 ans 6 mois - il y a 9 ans 5 mois #3331 par Jazz
[réglé] Liens en frontend a été créé par Jazz
Bonjour, j'ai un souci lors de l'insertion d'un lien vers un article dans l'éditeur :
en frontend, le lien créé est de la forme :

../[context-path]/index.php?option=com_content

exemple :

../Version%203.0/index.php?option=com_content&view=article&id=4:formation-n1&catid=10&Itemid=154


Si je change le context-path du site, je dois alors modifier tous les liens des articles.

Je n'ai pas ce problème lorsque je créé ce même lien dans le backend :

index.php?option=com_content&view=article&id=4:formation-n1&catid=10&Itemid=154


Mais versions installées sont les suivantes :
PHP 5.2.11
Joomla 1.5.14
Composant JCE 1.5.7 FR-EN
Plugin éditeur JCE 1.5.4 FR-EN

Avez-vous une idée ?
Merci d'avance
Dernière édition: il y a 9 ans 5 mois par Jazz.

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 9 ans 6 mois #3333 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet [réglé] Liens en frontend
Bonjour,
Je suis surpris par cette url : Version%203.0
A-t-elle un espace ? Si oui cela vient de là, jamais d'espace dans une URL.
Sinon, il faudrait essayer en désactivant les URL relatives dans Paramètres de l'Editeur de la gestion du groupe utilisé.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 9 ans 5 mois #3339 par Jazz
Réponse de Jazz sur le sujet [réglé] Liens en frontend
Bonjour

Merci pour cette réponse très rapide. Effectivement le problème vient du fait qu'il y a un espace dans l'url : "Version 3.0".
Cependant, il se semble que cela soit bien géré dans le backend.

J'ai une copie du site dont l'url est correct et il n'y a pas le souci.

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 9 ans 5 mois #3341 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet [réglé] Liens en frontend
Probablement que cela est dû au fait que les mesures de sécurité sont plus importante en frontal. Comme par défaut je ne mets jamais d'espace dans les URL, je n'ai jamais été confronté à ce problème.

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.159 secondes
Propulsé par Kunena

Rechercher