• Site mis à jour le 03 juin 2019

JCE et affichage de code javascript, php...

Plus d'informations
il y a 7 ans 10 mois #5236 par Brice
Bonjour,

Je viens de passer à la version 1.6 puis 1.7 de Joomla! avec JCE comme éditeur par défaut mais je rencontre un problème pour ce qui est d'inclure dans les articles du code (html, javascript, php) pour que celui-ci s'affiche dans les articles.

Auparavant, le plugin RJ_InsertCode (si mes souvenirs sont bons) fonctionnait bien mais aujourd'hui impossible de trouver un plugin qui fonctionne : CodeHighlighter, JL Highlighter et autres fonctionnent bien mais dès que j'enregistre l'article, le code est "nettoyé" -- euphémisme pour dire que le code non seulement intégré par le biais de ces plugins est "détruit" mais le reste des contenus qui suit le morceau de code est lui aussi bousculé.

La seule parade trouvée pour le moment est de passer directement par phpmyadmin pour ajoute le code, qui est ensuite parfaitement interprété.

Quelle solution adopter pour afficher du code au sein d'article et quelle configuration de JCE adopter pour que cela fonctionne ?

Merci et à bientôt.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 ans 10 mois #5264 par mihaly
Réponse de mihaly sur le sujet JCE et affichage de code javascript, php...
Hello,
Pas de plugin du genre à disposition pour l'instant, je tacherai de m'y mettre avant cet automne ;)
Il te faut surtout vérifier que tu autorises l'insertion de code HTML dans tes articles par les "Paramètres des articles" de Joomla!
Tu dois mettre "Aucun filtre" pour le groupe Joomla concerné.
Puis autoriser également le CSS voir le Javascript (si tu l'utilises) dans les paramètres du groupe JCE.

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 ans 10 mois - il y a 7 ans 10 mois #5275 par Brice
Réponse de Brice sur le sujet JCE et affichage de code javascript, php...
Salut,

Merci de ta réponse. Je viens de reprendre l'ensemble des points mentionnés et je pense que tout est bon :
- configuration globale des articles :


- configuration profil JCE :


- configuration générale JCE :


Il est à noter que dans ce dernier cas, j'ai essayé les deux options pour "Compatibilité Plug-in" sans plus de succès :/

Le truc, c'est que même sans passer par les "instructions" {code} fournies par ces plugins et en saisissant directement dans l'éditeur HTML les balises <pre class="brush:php"> par exemple, le code à l'enregistrement est totalement chamboulé :/

Quel plugin utilises-tu (si jamais tu en utilises un et si tu n'es pas resté en 1.5) ?

Merci et à+
Pièces jointes :
Dernière édition: il y a 7 ans 10 mois par Brice.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 ans 10 mois #5281 par mihaly
Réponse de mihaly sur le sujet JCE et affichage de code javascript, php...
Comme je l'ai dit, c'est aussi en gestion des articles de Joomla dans "Paramètres" qu'il faut autoriser l'insertion de code HTML en mettant "Aucun filtre" à ton groupe concerné.

Je n'ai hélas pas de plug-in à te proposer pour J 1.6+, je n'ai pas eu besoin de cette fonction sur les derniers sites que j'ai réalisés...

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 ans 10 mois #5284 par Brice
Réponse de Brice sur le sujet JCE et affichage de code javascript, php...
Désolé, un nettoyage du cache et les images avaient disparu :/

Il s'avère que cela semble fonctionner si j'utilise la bascule "Afficher/Masquer l'éditeur" pour insérer le code HTML, l'éditeur de code HTML de JCE semblant poser problème du coup.

A+

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 ans 10 mois #5289 par mihaly
Réponse de mihaly sur le sujet JCE et affichage de code javascript, php...
Merci de l'info, je vais tester pour voir si j'ai le même problème

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.297 secondes
Propulsé par Kunena

Rechercher