• Site mis à jour le 19 décembre 2018

Reglé-Editer un article en frontend - Invalid Form

Plus d'informations
il y a 7 ans 4 mois - il y a 7 ans 4 mois #5396 par jean82
Bonjour à tous,

Je cherche à éditer un article depuis le frontend. L'article s'ouvre en mode édition, il charge bien l'éditeur. Jusque-là tous va bien... le problème survient au moment de sauvegarder (click sur bouton "Save") de l'article, il y a un alert qui affiche "Invalid Form" et il ne se passe rien, pas d'erreur et l'édition reste ouverte. Le bouton "Cancel" marche bien... Le problème se produit sous n'importe quel navigateur.

J'avais déjà posté une question à ce sujet (lien: www.sarki.ch/jce/forum/11-jce-et-joomla-16x/5153-editer-un-article-en-frontend-ie-erreur ) j'avais pu résoudre le problème (avec l'aide de mihaly) en mettant à jour la version de JCE. Mais le problème ne se produisait que sous IE 7/8 pour mon ancien post.

Ces derniers temps, je fesais mes tests avec le superUser (car il n'y avait plus de problème), une fois les fonctionnalités mise en place, je les ai refait avec les autres utilisateurs (admin, éditeur,..) et j'ai de nouveau le même problème, donc je ne sais pas exactement depuis quand cela a recommencé...

Avant d'écrire ce post, j'ai commencé par vérifier si une nouvelle version de JCE était disponible, ce qui était le cas (v2.0.10). Je l'ai installé puis déconnecté/reconnecté, cela ne fonctionne toujours pas. Ensuite j'ai redémarré la machine et essayé sur une autre, mais ça n'a rien changé...

Je ne suis pas sûr que le problème vienne de JCE, mais je vous pose quand même la question. J'ai constaté que les catégories ne sont pas chargées lors de l'édition avec les utilisateurs qui ne font pas parti du groupe "SuperUser"... d'ou l'alert javacipt "Invalid form". En allant voir dans les fichiers du com_content et en fesant une print_r des données qu'il utilise pour le form, le "catid" est juste...

J'utilise Joomla 1.7.0 avec JCE 2.0.10 sous win7 64bit

Merci d'avance pour votre aide
Dernière édition: il y a 7 ans 4 mois par jean82.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 ans 4 mois #5406 par jean82
Réponse de jean82 sur le sujet Reglé-Editer un article en frontend - Invalid Form
Re,

Pour ceux qui rencontrerai le même problème :

Au final le problème n'était pas le même que j'avais rencontré, il était dû à la gestion des droits et non à l'éditeur. Il fallait donner l'autorisation, au groupe qui se trouve dans le niveau d'accès de la catégorie, de créer une catégorie afin de pouvoir sélectionner une catégorie en mode édition... sinon la liste des catégories reste vide et créer l'erreur "Invalid form" comme ce champ est obligatoire.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 ans 4 mois #5435 par mihaly
Réponse de mihaly sur le sujet Reglé-Editer un article en frontend - Invalid Form
Hello Jean,
Merci pour l'info ;)

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.154 secondes
Propulsé par Kunena

Rechercher