• Site mis à jour le 18 janvier 2019

Problème attribution répertoire [OK]

  • ctoinou
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 5 ans 11 mois - il y a 5 ans 10 mois #7953 par ctoinou
Problème attribution répertoire [OK] a été créé par ctoinou
Bonjour

je suis sur joomla 2.5.9 avec jce 2.3.1

Mon problème est le suivant:
je voudrais attribuer des répertoire par groupe d'utilisateur.
Donc je crée différent groupe et j'attribue les répertoires .
le souci est que quand l'utilisateur ouvre l'explorateur de jce pour sélectionner les photos ou en uploder une il a quand même accès au autre répertoire.
j'ai même essayer d'enlever l'affichage des sous répertoire mais cela ne fonctionne pas.
J'ai l'impression que certaine fonction du panneau de config n'on pas d'influence sur le plugin
avez vous déjà rencontré le problème?
Vous remerciant par avance.
Dernière édition: il y a 5 ans 10 mois par mihaly.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 5 ans 10 mois #7969 par mihaly
Réponse de mihaly sur le sujet Problème attribution répertoire [OK]
Bonjour,
Vous avez créé les groupes dans Joomla c'est ça ?

Si la barre d'outils doit être la même pour chaque groupe, il est possible de ne créer qu'un seul profil JCE ; il faut cocher les groupes Joomla souhaités dans le premier onglet du profil (Généralités).
Si la barre d'outils doit être différente pour chaque groupe, il faut créer un profil JCE pour chaque groupe en cochant le groupe adéquat dans le 1er onglet "Généralités"

Dans l'onglet "Paramètres de l'éditeur", sous "Fichier système -> Chemin du répertoire principal" vous pouvez indiquer le dossier devant être destiné au profil.
En survolant le titre de ce champ (Chemin du répertoire principal), il y a une description complètes des différentes valeurs qu'il est possible de mettre.
Pour spécifier automatiquement le dossier au nom du groupe, il suffit d'ajouter "$group" dans le chemin. Exemple : images/$group

Ainsi, que le profil JCE soit attribué à un groupe ou plusieurs groupes Joomla, dès qu'un utilisateur utilise JCE, si le dossier n'est pas encore créé, il le sera automatiquement au nom du groupe joomla, et l'utilisateur ne verra que le contenu de ce dossier.

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

  • ctoinou
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 5 ans 10 mois #7974 par ctoinou
Réponse de ctoinou sur le sujet Problème attribution répertoire [OK]
bonjour

merci de ton aide

j'ai bien compris le principe des différents groupes et attribué des répertoires sur certain groupe comme écrit dans les aides.
Mais quand je me sert par exemple du compte créé pour tester attribuer juste avec des droits d'éditeur j'ai quand même accès à tout les répertoires de la racine du site.
je reste à ta disposition.

Haaa Haaa ca y est je viens de trouver

bon en te répondant j'ai testé plusieurs choses et j'ai trouver mon problème

Explication :

J'avais tout fait bien sauf que sur les différents profils j'avais laissé coché l'espace d'administration dans les attributions j'ai décoché et j'ai bien accès qu'au répertoire voulu.

Pour moi ce n'est pas très logique pars que je pense que cette option à été créer pour avoir accès à l'espace d'administration mais ne pouvoir atteindre qu'un seul répertoire?

Connexion ou Créer un compte pour participer à la conversation.

  • ctoinou
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 5 ans 10 mois #7975 par ctoinou
Réponse de ctoinou sur le sujet Problème attribution répertoire [OK]
Re Bonsoir

Bon la solution n'est pas celle là je me suis un peux emballé

j'ai crus être arrivé à la solution car dans le pop-up de gestion de fichier l'encart "dossier" avais disparu.
Mais en cliquant sur up je suis revenus à la racine ce qui ne m'avance pas
La chose de bien c'est qu'ils n ont pas accès au fichier système.

Je continue de creuser

Connexion ou Créer un compte pour participer à la conversation.

  • ctoinou
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 5 ans 10 mois #7976 par ctoinou
Réponse de ctoinou sur le sujet Problème attribution répertoire [OK]
Yes!!!!

ça y est j'ai trouvé la c'est bon et ça marche tiptop

bon mon problème venez de l'ordre du profil ce qui donné accès à trop de chose
je n'avais pas compris

je trouve que c'est une fonction qui recoupe les autres mais cela doit avoir une utilité si non ça ne serai pas là.

excuse moi d'avoir un peux spammer le forum mais j'ai l'espoir que cela puisse servir

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 5 ans 10 mois #7979 par mihaly
Réponse de mihaly sur le sujet Problème attribution répertoire [OK]
Super, content pour toi ;)

L'ordre des profils a son importance dans le cas où un utilisateur se retrouve dans plusieurs profils. Normalement c'est le premier qui a priorité sur les suivants, c'est bien ça dans ton cas ?

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.108 secondes
Propulsé par Kunena

Rechercher