• Site mis à jour le 03 juin 2019

Jce ne se charge plus apres ugrade de Jooomla 2.5.8 vers 3.6

  • roland38
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 4 ans 4 mois #10321 par roland38
Bonjour,

JCE ne s'affiche plus après un upgrade de 2.5.28 vers 3.6 en frontal et en administration.
J'ai désinstallé et réinstallé l'editeur (2.4.6), supprimé les options de compression .
Plugin Tinymce 4.1.2, JB type 2.1.4
J'ai une page html blanche et avec firedebug j'ai une fatal erreur :

<head>
<script type="text/javascript">
Joomla.submitbutton = function(task)
{
if (task == 'article.cancel' || document.formvalidator.isValid(document.id('item-form')))
{
<br />
<b>Strict Standards</b>: call_user_func_array() expects parameter 1 to be a valid callback, non-static method WFJbtypePluginConfig::getConfig() should not be called statically in <b>/wwwtest/administrator/components/com_jce/models/editor.php</b> on line <b>648</b><br />
<br />
<b>Fatal error</b>: Call to undefined method JModel::getInstance() in <b>/wwwtest/components/com_jce/editor/tiny_mce/plugins/jbtype/classes/config.php</b> on line <b>16</b><br />
</script>
</head>
<body>
</body>
</html>

Merci pour votre aide

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 4 ans 4 mois #10322 par mihaly
Hello,
Vérifie que ta version JB Type soit compatible Joomla 3.x, à priori ça bloque là dessus.
C'est peut-être pas le plugin pour JCE qui est incompatible mais celui pour Joomla.

Mihàly Marti alias Sarki
Les utilisateur(s) suivant ont remercié: roland38

Connexion ou Créer un compte pour participer à la conversation.

  • roland38
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 4 ans 4 mois - il y a 4 ans 4 mois #10327 par roland38
Re,
La version de JB type 1.9.0 est la dernière compatible 2.5-3.0.
Mais je viens de voir qu'il y a une version "JCE JB Type Plugin v2.0 - compatible with JCE v2.x"
Mais comment l'installer? il ne s'installe pas via le menu gestion des extensions.
Dernière édition: il y a 4 ans 4 mois par roland38.

Connexion ou Créer un compte pour participer à la conversation.

  • roland38
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 4 ans 4 mois - il y a 4 ans 4 mois #10328 par roland38
C'est bon JCE 'affiche bien apres install du plugin JCE JB Type Plugin v2.0 - compatible with JCE v2.x

Merci
Dernière édition: il y a 4 ans 4 mois par roland38.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 4 ans 4 mois #10330 par mihaly
Ok, bonne chose.
A installer donc par le gestionnaire d'installation de JCE et non de Joomla, je le dis pour d'autres qui liraient le sujet ;)

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.173 secondes
Propulsé par Kunena

Rechercher