• Site mis à jour le 11 mars 2019

Probleme en mode responsive avec JCE

  • Lan89
  • Portrait de Lan89 Auteur du sujet
  • Hors Ligne
  • Rédacteur Occasionnel
  • Rédacteur Occasionnel
Plus d'informations
il y a 4 ans 15 heures - il y a 3 ans 11 mois #10451 par Lan89
Probleme en mode responsive avec JCE a été créé par Lan89
Bonjour ...

Je rencontre plusieurs problèmes avec la rédaction des articles et surtout leur mise en forme ...

L'utilisation du tableur, ou de marges d'alignement met directement en javel le site sur les smartphones ...
D'autre part j'ai essayé de faire, avec deux fichiers différents un rollover sur une image,ça ne fonctionne pas ...
Bref le rédacteur du site s'arrache les cheveux, il a déjà été obligé de refaire les articles qu'il avait en premier lieu réalisé avec un tableur, bon là je viens en plus de lui expliquer qu'il ne faut pas, visiblement ,utiliser de marges ... rebelote il va falloir revoir tous les articles ?

Merci par avance de votre retour d'expérience et je suis preneur de toute idée

configuration : joomla 3.4 dernière version , Jce avec toutes les options complémentaires installées ...

Belle journée à tous

Lan
Dernière édition: il y a 3 ans 11 mois par mihaly. Raison: Réglé

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 ans 11 mois #10461 par mihaly
Réponse de mihaly sur le sujet Probleme en mode responsive avec JCE
Hello,
En effet l'utilisation des tableaux est à éviter pour des contenus car l'affichage est problématique sur smartphone, de plus les systèmes de lecture (moteurs de recherche ou malvoyants) lisent mal dans les tableaux.

Quand tu parles de marge, tu veux dire dans des tableaux ?

Pour le problème du Rollover, ce sujet a été traité récemment, consulte le post pour voir s'il répond à tes questions, je ne veux pas répéter à chaque fois.

A l'avenir, il serait bien que tu fasses des sujets différents selon les problèmes ;)

Mihàly Marti alias Sarki
Les utilisateur(s) suivant ont remercié: Lan89

Connexion ou Créer un compte pour participer à la conversation.

  • Lan89
  • Portrait de Lan89 Auteur du sujet
  • Hors Ligne
  • Rédacteur Occasionnel
  • Rédacteur Occasionnel
Plus d'informations
il y a 3 ans 11 mois - il y a 3 ans 11 mois #10464 par Lan89
Réponse de Lan89 sur le sujet Probleme en mode responsive avec JCE
Merci pour ta réponse et que mon expérience soit utile aux autres ...

Après avoir mûrement réfléchi , édité les articles qui posaient problème, je me suis rendu compte que dans l'éditeur je ne pouvais pas modifier la position des images ... bizarre, bizarre...
Je clique sur une image, je vois bien qu'elle en alignement gauche, mais aussi bien en mode édition de l'article que dans le frontend il reste une énorme marge à gauche ...

Je regarde bien sûr les options avancées de l'éditeur 'Définir précisément un style ', rien non plus...j'ai cherché pendant des heures... et puis je me suis souvenu que le rédacteur des articles sur le site avait une envie pressante de s'intéresser au html ...ce que je lui avait formellement déconseillé .

Et Bingo ! je me suis plongé dans le code sur tous les articles, je me suis rendu compte que certaines ' leftmargin ' étaient passées de 30 par défaut à 150, 180 ou 240 px !

Comme un couillon je n'avais pas limité les accès au ' default ' ...et de fait interdit l'accès au code source des articles ...depuis j'ai créé un accès ' restreint '...

La facture pour le nettoyage complet de tous les articles du site, sera évidement à la hauteur des heures passées .. ça risque de ' piquer ' ...

Bref, si vous avez des rédacteurs sur votre site, créez leur un profil à part et enlevez absolument l'accès au code source


Pour le rollover, promis je vais faire une recherche
Dernière édition: il y a 3 ans 11 mois par Lan89.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 ans 11 mois #10465 par mihaly
Réponse de mihaly sur le sujet Probleme en mode responsive avec JCE
Si tu veux éviter la modification des styles par défaut, il te faut également désactiver l'accès à l'éditeur de styles xhtml, l'icône avec le double AA
Pour supprimer le retrait augmenté, tu peux soit utiliser l'icône de suppression de retrait (retrait à gauche) ou la gomme

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 ans 11 mois #10466 par mihaly
Réponse de mihaly sur le sujet Probleme en mode responsive avec JCE
Le sujet sur le rollover est ici: www.sarki.ch/jce/forum/problemes-divers/9309-le-rollover-ne-marche-pas
Si tu n'y vois pas la solution à ton problème relance-moi

Mihàly Marti alias Sarki
Les utilisateur(s) suivant ont remercié: Lan89

Connexion ou Créer un compte pour participer à la conversation.

  • Lan89
  • Portrait de Lan89 Auteur du sujet
  • Hors Ligne
  • Rédacteur Occasionnel
  • Rédacteur Occasionnel
Plus d'informations
il y a 3 ans 11 mois #10467 par Lan89
Réponse de Lan89 sur le sujet Probleme en mode responsive avec JCE
Pour le rollover je vais regarder ton lien

Pour ce qui est du mode en responsive du site, il passe maintenant à 200% tous les tests et même la vérification, sur tous mes articles, en les analysant par la page de test de ' Google Developers '

www.google.com/webmasters/tools/mobile-friendly/

Voilà une bonne leçon pour les webmaster qui autorisent l'accès aux rédacteurs sur les parties ' sensibles ' de JCE de leur site ...

Faut blinder !

lol

Je te remercie encore pour ton aide...

Lan

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.145 secondes
Propulsé par Kunena

Rechercher