• Site mis à jour le 19 décembre 2018

Problème d'affichage wysiwyg dans l'éditeur

Plus d'informations
il y a 2 ans 4 semaines - il y a 2 ans 4 semaines #11443 par casdyn
Bonjour,

Le problème : l'affichage dans l'éditeur n'est pas wysiwyg, il ne l'est pas non plus dans Preview. C'est très gênant, en particulier pour les caractères gras.

Je suis sous la dernière version de Joomla et la dernière version de JCE. Dans l'administration de JCE, j'ai choisi "Fichiers CSS par défaut du template", en laissant vide l'éditeur de classe.

Pouvez-vous me mettre sur la piste de la solution ?
Merci d'avance
Dernière édition: il y a 2 ans 4 semaines par mihaly. Raison: Ajout icône Réglé

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 4 semaines #11445 par mihaly
Réponse de mihaly sur le sujet Problème d'affichage wysiwyg dans l'éditeur
Hello,
Si l'affichage dans l'éditeur n'est pas wysiwig alors c'est que tu as un problème.
Quelle version utilises-tu de JCE ?
Peux-tu mettre une capture de ton problème que je puisse voir ?
A mon sens tu as un problème de compression JavaScript ou Gzip qq part, config Joomla ou JCE, ou template ou encore plugin tel CH optimizer

Une fois ton problème d'affichage de l'éditeur réglé, il te faudra vérifier si le preview n'est toujours pas correct, et si oui il te faudra adapter le CSS appelé, possible qu'il ne te faudra pas prendre celui du template, cela dépend du template utilisé...

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 4 semaines #11446 par casdyn
Réponse de casdyn sur le sujet Problème d'affichage wysiwyg dans l'éditeur
JCE 2.6.1

Ci joint 3 copies d'écran : front, editeur JCE et Preview JCE





S'il y a un problème de compression JavaScript ou Gzip qq, config Joomla ou JCE, ou template ou encore plugin tel CH optimizer, il faudra m'expliquer un peu de quoi il s'agit.

Merci
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 4 semaines - il y a 2 ans 4 semaines #11447 par mihaly
Réponse de mihaly sur le sujet Problème d'affichage wysiwyg dans l'éditeur
Ok, je crois que ce n'est qu'un problème lié au fichier de ton template qui est chargé, qui a certainement une valeur attribuée au gras qui lui dit d'être normal.
La plupart des templates appellent plusieurs feuilles de styles qui ont des noms différents selon leurs auteurs, mais il y a en général une feuille nommée template.css dans la plupart d'entre eux, c'est cette feuille qui est chargée par défaut.
Si l'auteur du template ne mets pas uniquement dans ce fichier ce qu'il faudrait avoir comme styles dans l'éditeur, les styles affichés ne correspondent pas...
Parfois certains auteurs proposent alors un fichier nommé editor.css qui est celui qu'il faut déclarer dans la config JCE.
Si ce fichier n'existe pas, alors idéalement il faudrait le faire sois-même en copiant dans les différentes feuilles de styles du template les styles à retrouver dans l'éditeur, puis il faudrait déclarer dans la config JCE ce fichier.
Si tu n'as pas les connaissances pour créer ce fichier, tu peux au moins charger les styles HTML par défaut à la place de la feuille de style du template. Pour cela, il te faut aller dans la config JCE et sélectionner "Oui" pour "Réinitialiser les styles", puis "Défaut" pour "Classes CSS dans l'éditeur", tu auras ainsi les styles HTML de base et tu récupéreras ainsi ton gras.

Je ne débat pas ici sur les compressions car voyant tes captures je ne pense pas que ce soit ça, contrairement à ce que tu as dis dans ton 1er message tu as bien un affichage wysiwyg dans l'éditeur, si ce n'était pas le cas tu aurais du code affiché.
Puis ce sujet a tellement été expliqué dans ce forum que je te renverrai sur un de ces messages, mais tu peux également si nécessaire faire une recherche toi-même ;)

Mihàly Marti alias Sarki
Dernière édition: il y a 2 ans 4 semaines par mihaly.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 4 semaines #11452 par casdyn
Réponse de casdyn sur le sujet Problème d'affichage wysiwyg dans l'éditeur
Ok, Merci :)

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.161 secondes
Propulsé par Kunena

Rechercher