• Site mis à jour le 18 janvier 2019

Problème warning concernant com_jce

  • technopol
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 1 an 7 mois - il y a 1 an 6 mois #11604 par technopol
Problème warning concernant com_jce a été créé par technopol
Bonjour,

Impossible d'accéder au backend et frontend de mon site local sous Wamp.

backend

Après page de loggin affichage d'une page Warning : (!) Warning: require_once(G:\Wamp64\www\ordinosaure.local/components/com_jce/editor/libraries/classes/editor.php): failed to open stream: No such file or directory in G:\Wamp64\www\ordinosaure.local\administrator\components\com_jce\includes\loader.php on line 48

frontend

Erreur 403 - Vous n'êtes pas autorisé à accéder à cette ressource.

- Il existe bien un fichier " loader.php " dans l'arborescence /administrator/.../...
- La modification de $error_reporting = 'simple'; en 'none' fait passer la page Warning en page blanche"
- la ligne 48 du loader.php citée donne ça :
$rs = require_once $base.'/'.implode('/', $parts).'.php';

$paths[$keyPath] = $rs;


comme je vois dans les deux arborescences du warning ... \com_jce\... je me demande si quelqu'un a déjà eu ce problème et s'il y a un rapport avec l'éditeur ?

Merci d'avance
Dernière édition: il y a 1 an 6 mois par mihaly.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 7 mois #11605 par mihaly
Réponse de mihaly sur le sujet Problème warning concernant com_jce
Hello,
Avais-tu déjà utilisé ce site sous Wamp, et le serveur, ou est-ce la première fois ?
Sur quelle version PHP es-tu ? Si ce n'est pas une version assez récente cela pourrait expliquer l'erreur.
Sache en tout cas qu'il n'y a aucune raison de modifier les fichiers de JCE et que cela fonctionne avec Wamp, il faut juste voir quelle configuration tu as car Wamp n'est pas configurer par défaut pour fonctionner correctement avec Joomla sans erreur, il y a qqs adaptations à faire.
Personnellement je n'aime pas beaucoup ce serveur et préfère le UwAmp qui est plus léger, tu as une version ici que j'ai adapté pour fonctionner correctement avec Joomla : www.joomlatutos.com/public/UwAmp.zip

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

  • technopol
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 1 an 7 mois #11608 par technopol
Réponse de technopol sur le sujet Problème warning concernant com_jce
Merci de me répondre Mihaly,
Désolé de n'avoir pas mis ma config dans le premier post :
Wamp : 3.0.6
Apache : 2.4.23
Php : 7.0.10
Joomla : 3.7.2 (mise à jour récente)

J'ai travaillé sur le site depuis près de 3 mois sans problème . Un warning php au début non bloquant car passé en "simple" dans config.php. Merci pour le Uwamp ça pourra éventuellement servir en dernier recours.

Je suis repassé en "défault" suite à ce warning qui me bloque j'ai un "Fatal error: require_once():... avec la même arborescence de fichier "loader.php"

- Fatal error: require_once(): Failed opening required 'G:\Wamp64\www\ordinosaure.local/components/com_jce/editor/libraries/classes/editor.php' (include_path='.;C:\php\pear') in G:\Wamp64\www\ordinosaure.local\administrator\components\com_jce\includes\loader.php on line 48 -

Je suis encore nul en php mais avec l'aide de l'ami Google j'ai fait un test is_file qui me répond "true" (ce qui voudrait dire que le fichier existe bien)dans l'affichage de la page d'accès à l'administration avant les messages de warning et Fatal error.

Comme les messages font référence à ... /component/com_jce/... je me dit que ça a à voir avec ce fameux loader.php et son require_once.

Est ce qu'il y aurait une façon de shunter cet appel à loader.php pour débloquer l'accès à l'administration et faire ensuite le ménage dans les composants ?

@+
Pierre

Connexion ou Créer un compte pour participer à la conversation.

  • technopol
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 1 an 7 mois #11610 par technopol
Réponse de technopol sur le sujet Problème warning concernant com_jce
J'ai réussi à débloquer l'accès à l'administration de mon site en désinstallant manuellement JCE dans les tables de ma base en suivant ce Tutoriel :woohoo:

J'ai ensuite vérifié que le composant et les plugins étaient supprimés. C'était le cas, mes articles n'avaient plus d'éditeurs. J'ai donc voulu temporairement paramétrer Tinymce dans ma configuration système mais je suis tombé sur une erreur : -"0 Class 'ConfigControllerHelper' not found"-
En vérifiant il se trouve en plus que je ne peux plus afficher mon frontend erreur 403.

Sans en tenir compte, j'ai réinstallé la version de JCE (2.6.15) et JCE MediaBox sans problème.

On peut considérer que mon problème PHP concernant com_JCE est résolu. Pour le reste, j'ai peut être été trop loin dans le nettoyage de la base (?) et je vais essayer de solutionner ça. Si je rame trop je me permettrait de poster un nouveau sujet.

Merci encore.

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.160 secondes
Propulsé par Kunena

Rechercher