• Site mis à jour le 03 juin 2019

Soucis affichage

  • provence
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 10 ans 7 mois - il y a 10 ans 6 mois #2137 par provence
Soucis affichage a été créé par provence
bonjour à tous,
Sous joomla 1.5.8, l'install de la dernière version de JCE s'est bien passée mais impossible d'afficher quoi que ce soit de le config de JCE, du panneau de contrôle etc...message : /homepages/41/d265498764/htdocs/administrator/components/com_jce/cpanel/views/cpanel/tmpl/default.php on line 28.

Comment résoudre ce souci ?
Merci d'avance.
Dernière édition: il y a 10 ans 6 mois par . Raison: svp, pas d'apostrophe dans les titres des sujets (pour moteurs de recherche)

Connexion ou Créer un compte pour participer à la conversation.

  • Visiteur
  • Visiteur
il y a 10 ans 7 mois #2139 par
Réponse de sur le sujet Soucis affichage
Hello, je ne sais pas quel hébergeur tu as mais cela vient de là.
Par défaut les injections MySQL dans la Base de données se font avec un chemin relatif : #__nom-de-la-table...
Chez certains hébergeur, le chemin doit être réél tel : jos_nom-de-la-table... dans la mesure oû tu n'as pas changer le préfixe par défaut de jos_ proposé à l'installation.
Désinstalle le composant qui te désinstallera le tout de JCE.
Je te joins une version du composant avec les insertions MySQL corrigées. Essaie de l'installer avant même le reste et vérifies si tu as la même erreur.
Redis moi. ;)

Fichier attaché :

Nom du fichier : com_jce_15..._jos.zip
Taille du ficher :165 ko
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

  • provence
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 10 ans 7 mois #2142 par provence
Réponse de provence sur le sujet Soucis affichage
re bonjour,
Tout est fait dans l'ordre que tu m'as indiqué : désinstall JCE puis réinstall avec le fichier proposé, rien n'y fait toujours la même erreur : je suis hébergé chez 1 and 1. Ce qui est curieux c'est que j'ai d'autres sites chez 1 and 1 avec JCE également et je n'ai pas ce souci !!!
voici le message : Fatal error: Call to undefined function: quickiconbutton() in /homepages/41/d265498764/htdocs/administrator/components/com_jce/cpanel/views/cpanel/tmpl/default.php on line 28...
Merci encore, je ne dois pas être le seul à avoir ces problèmes...:lol:

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 10 ans 7 mois - il y a 10 ans 7 mois #2144 par BaptisteToutCour
Réponse de BaptisteToutCour sur le sujet Soucis affichage
J'ai eu le même problème chez 1&1. Mais le message d'erreur est parfaitement explicit. Rends toi ligne 28 du fichier /homepages/41/d265498764/htdocs/administrator/components/com_jce/cpanel/views/ cpanel/tmpl/default.php . Modifie le nom de la fonction en rajoutant
JCEHelper::

Ca devrait te donner un truc du genre:
<?php defined('_JEXEC') or die('Restricted access'); ?>
 
<?php
 
	JToolBarHelper::title( JText::_( 'JCE Administration' ), 'cpanel.png' );
 
	jceToolbarHelper::help( 'cpanel' );		
 
?>
 
<table class="admintable">
 
    <tr>
 
        <td width="55%" valign="top" colspan="2">
 
		<div id="cpanel"><?php
 
			$link = 'index.php?option=com_jce&amp;type=config';
 
			JCEHelper::quickiconButton( $link, 'icon-48-config.png', JText::_( 'Configuration' ) );
 
 
 
			$link = 'index.php?option=com_jce&amp;type=plugin';
 
			JCEHelper::quickiconButton( $link, 'icon-48-plugin.png', JText::_( 'Plugins' ) );
 
 
 
			$link = 'index.php?option=com_jce&amp;type=group';
 
			JCEHelper::quickiconButton( $link, 'icon-48-user.png', JText::_( 'Groups' ) );
 
 
 
			$link = 'index.php?option=com_jce&amp;type=install';
 
			JCEHelper::quickiconButton( $link, 'icon-48-install.png', JText::_( 'Install' ) );
 
 
 
			if( !JCEHelper::checkEditorInstall() && JCEHelper::checkEditorPath() ){
 
				$link = 'index.php?option=com_jce&amp;type=fixinstall-editor';
 
			JCEHelper::quickiconButton( $link, 'icon-48-cpanel.png', JText::_( 'Install Editor' ) ); 
 
			}
 
			if( !JCEHelper::checkPlugins() ){
 
				$link = 'index.php?option=com_jce&amp;type=fixinstall-plugins';
 
			JCEHelper::quickiconButton( $link, 'icon-48-cpanel.png', JText::_( 'Fix Plugins' ) ); 
 
			}
 
			if( !JCEHelper::checkGroups() ){
 
				$link = 'index.php?option=com_jce&amp;type=fixinstall-groups';
 
				JCEHelper::quickiconButton( $link, 'icon-48-cpanel.png', JText::_( 'Fix Groups' ) ); 
 
			}
J'ai eu ce même problème que j'ai résolu plutôt intuitivement. Evidemment,certains diront que c'est bien moche tout ca .... mais ca passe faut croire. En esperant t'avoir aidé.

Baptiste dlR

(moi aussi j'ai un problème qui urge!
Dernière édition: il y a 10 ans 7 mois par BaptisteToutCour.

Connexion ou Créer un compte pour participer à la conversation.

  • provence
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 10 ans 7 mois #2145 par provence
Réponse de provence sur le sujet Soucis affichage
merci mais j'ai un autre souci : Parse error: syntax error, unexpected ''', expecting ')' in /homepages/41/d265498764/htdocs/libraries/simplepie/simplepie.php on line 9972

bon là j'avoue que je décroche un peu sauf si solution en vue...
merci à tous...

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 10 ans 7 mois #2146 par BaptisteToutCour
Réponse de BaptisteToutCour sur le sujet Soucis affichage
Le message est encore clair ... copie-colle cette ligne 9172 pour qu'on voit ce qu'elle raconte....

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.240 secondes
Propulsé par Kunena

Rechercher