• Site mis à jour le 03 juin 2019

Problème affichage code html avec Advanced Code

  • ytahiti
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 10 ans 6 mois - il y a 10 ans 6 mois #2169 par ytahiti
Bonjour,

J'ai un problème d'affichage lorsque je clique sur Advanced Code Editor pour avoir le code HTML, j'obtiens ma première page du site au format html telle qu'elle est vue sur le site sans aucun code.
Je n'avais pas ce problème en local. (je viens de migrer tout le travail en test sur le serveur online où est hébergé mon site).
Je travaille avec Joomla 1.5.7 en mode sef (j'ai testé de désactiver la fonction SEF sans que cela change quoi que ce soit).

J'ai
JCE Admin Component 1.5.0 et JCE Editor plugin 1.5.1 quer j'ai ré installé sans amélioration.
Je n'ai pas ce problème pour le pop up des insertions d'images ou de liens.

C'est un problème car je souhaiterai modifier le template de ma newsletter acajoom et je ne peux accéder au code (la fonction [show/hide] n'est pas opérationnelle sur mes composants..


Auriez-vous une idée?
Merci pour votre aide
Dernière édition: il y a 10 ans 6 mois par YRrT_mihaly. Raison: svp, pas d'apostrophe dans les titres des sujets (pour moteurs de recherche)

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 10 ans 6 mois - il y a 10 ans 6 mois #2171 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet Problème affichage code html avec Advanced Code
Je pense que c'est soit un problème de script avec une autre extension (si uniquement en frontal), soit un problème de chemin du site dans le fichier configuration.php
Certains hébergeurs ont besoin d'un appel particulier.
Je fais une mise à jour du Pack ce week-end et le mettrai à disposition lundi. Je te conseille de tester avec cette future version si cela ne vient pas de la config de ton hébergeur.
Dernière édition: il y a 10 ans 6 mois par YRrT_mihaly.

Connexion ou Créer un compte pour participer à la conversation.

  • ytahiti
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 10 ans 6 mois #2179 par ytahiti
Réponse de ytahiti sur le sujet Problème affichage code html avec Advanced Code
Merci pour cette réponse rapide.
J'ai le même problème que ce soit en frontend ou en backend sur Online et rien en local (wamp server).
Je n'ai pas ce problème avec TinyMCE.

J'ai regardé le code de plugins/editors/jce/tiny_mce/plugins/advcode/js/advcode.js qui semble gérer le contenu du pop up de l'éditeur html en utilisant le document.getElementById('htmlSource') mais je ne vois pas ce qui cloche maintenant.

J'ai regardé le contenu du fichier configuration.php et je ne vois pas ce qui ne marche pas.

C'est sans doute un problème avec online?
Comme j'ai plusieurs sous-dossier dans mon /www/, j'ai un fichier index.php qui contient un renvoi de type header("Location: ) et c'est cette page que je retrouve dans le pop up de l'advanced editor html de jce.

J'ai fait l'essai de supprimer ce renvoi dans le www/index.php mais cela ne change rien.

J'essaierai la mise à jour proposée demain.

Merci en tous cas pour ta réponse très rapide et un we de surcroit.

Connexion ou Créer un compte pour participer à la conversation.

  • ytahiti
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 10 ans 6 mois #2239 par ytahiti
Réponse de ytahiti sur le sujet Problème affichage code html avec Advanced Code
J'ai mis en place la dernière version JCE depuis le pack mis à disposition sur votre site mais cela n'a pas corrigé mon problème.

J'ai laissé un message sur le forum JCE mais sans réponse à ce jour.
Il y avait une nouvelle version test pour l'advanced editor sur le forum JCE; je l'ai installé mais sans plus de succès.

Sauriez-vous quel est le fichier.js qui gère l'affichage du contenu de la page dans l'éditeur en mode script et comment il procède?
Merci pour votre aide.

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 10 ans 6 mois #2242 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet Problème affichage code html avec Advanced Code
Bonjour,
Je ne peux malheureusement pas vous aider plus.
Si tout fonctionne en local mais pas en distant, que les répertoires nécessaires en mode écriture le sont bien en distant, ce ne peux qu'être une configuration serveur.
Voir si sur le forum Joomla! FR d'autres parlent du même problème, ou contacter l'hébergeur...

Connexion ou Créer un compte pour participer à la conversation.

  • ytahiti
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 10 ans 6 mois #2244 par ytahiti
Réponse de ytahiti sur le sujet Problème affichage code html avec Advanced Code
Bonjour,

Merci pour votre aide et pour votre site très intéressant et très bien fait.
J'espère finir par comprendre ce qui cloche

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.151 secondes
Propulsé par Kunena

Rechercher