• Site mis à jour le 18 janvier 2019

Probleme de slashs "////" avec Artforms

  • clubertonight
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 10 ans 10 heures #2470 par clubertonight
Probleme de slashs "////" avec Artforms a été créé par clubertonight
Bonjour à tous,

j'ai téléchargé et installé la version "Pack d'installation de Joomla! 1.5.9 avec JCE 1.5" qui est superbe et vraiment agréable à utiliser.
Cependant j'ai un probleme avec le composant Artforms...

En effet, lorsque je crée un formulaire, dans le texte qu'on introduit, dés que je mets un appostrophe "'", ce dernier est automatiquement remplacé par un slash "/".
Qui plus est, à chaque fois que je modifie le formulaire, un slash de plus se rajoute...:huh: :huh:
Donc là sur ce coup la, vraiment rien de bon...

Aussi, un autre souci, toujours avec Artforms, le texte en front end apparait en gras et je ne peux pas modifier le style, la couleur etc...

Une idée sur tout celà ??

Merci d'avance.

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 9 ans 11 mois #2475 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet Probleme de slashs "////" avec Artforms
Hello Clubertonight,
L'éditeur dans Artforms fonctionne correctement.
Je ne me souviens plus où, mais j'ai remarqué en effet qu'il y avait un bogue avec les apostrophes mais, qui est lié à ArtForms.
Prend l'habitude de ne jamais mettre d'apostrophe dans des champs de formulaire. Ceux-ci sont traités par PHP qui utilise l'apostrophe dans son code, raison du \ qui permet de dire que c'est un apostrophe.
Cette ajout systématique à chaque édition, signifie qu'il n'y a pas de contrôle dans le script pour voir s'il y a déjà un \.
Si ton clavier te le permet, utilise l'apostrophe réelle (l'accent) ´ et non '

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 9 ans 7 mois #3010 par ker44
Réponse de ker44 sur le sujet Probleme de slashs "////" avec Artforms
Bonjour Mihaly,
J'utilise Artforms aussi depuis peu et j'ai un soucis dont je ne sais s'il provient de JCE ou Artforms.
En fait lorsque je créés mon formulaire et que j'introduis un texte en introduction aucun éditeur n'apparaît. Je ne peux donc pas agir du tout sur la couleur, la taille ect... du texte.
Celui-ci apparaît en plus en gras dans le frontend !!
Je suis sous joomla 1.5.7, Artform Version: 2.1b7.1, JCE 1.5.0b.
As-tu un avis sur la question ?

Je te remercie d'avance de ton aide et te souhaite une très bonne journée.

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 9 ans 7 mois #3014 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet Probleme de slashs "////" avec Artforms
Hello,
Je te conseille de faire la mise à jour de Joomla!, de JCE et de Artforms.
Artforms est dispo en version 2.17.2 à cette adresse : www.sarki.ch/joomla15

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 9 ans 7 mois #3015 par ker44
Réponse de ker44 sur le sujet Probleme de slashs "////" avec Artforms
Bonjour Mihaly,

J'y pense, j'y pense.
On me préconise même avant tout de faire une mise à jour de joomla (je suis en 1.5.7) puis de JCE et enfin de Artforms.
Comme je l'ai exposé sur le forum Aide-joomla, je n'ai jamais procédé à une mise à jour de joomla et j'avoue j'appréhende pas mal les soucis que je pourrais avoir. D'autant que le site dont je m'occupe est celui d'une assos sportive et qui organise une compétition pour laquelle on a préparé un formulaire (artforms) d'inscrition en ligne. Alors je ne peux pas me permettre d'avoir un bug en ce moment.
Par ailleurs on me dit que cela se passe bien d'habitude et que je règlerais très certainement mes petits soucis...
Je suis assez tenté mais je ne sais pas trop par ou commencé ?

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 9 ans 7 mois #3020 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet Probleme de slashs "////" avec Artforms
Juste pour informer les autres de la suite de ton aventure dans ce sujet :
jce.sarki.ch/index.php/problemes-divers/3016-mise-a-jour-jce.html

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.107 secondes
Propulsé par Kunena

Rechercher