• Site mis à jour le 22 mars 2019

exportation db local problème espace balise p

Plus d'informations
il y a 9 ans 11 mois - il y a 9 ans 11 mois #2823 par mfalla
Bonjour,

tout d'abord, félicitation pour cet éditeur! Je trouve qu'il est vraiment bien fait et qu'il mériterait d'être installé de base dans joomla. Pour ma part je l'installe par défaut dans tous les sites que je crée.

Après quelques recherches sur google et sur ce forum, je n'ai pas trouvé de réponse à ma question.

J'utilise com_jce_152_FR-EN et plg_jce_152_FR-EN. Dans la configuration > Formatage/Styles > Nouvelle ligne, j'utilise "paragraphe".
Donc ça me fait bien des <p> </p> lorsque je fais un enter dans la console.

Cependant, lorsque j'exporte ma DB local vers un serveur quelconque via phpMyAdmin, mon article est le même que celui de la base en local à l'exception de l'espace entre les <p> </p> qui fait une espèce de tabulation bizarre. (j'ai eu le même problème sur plusieurs serveurs d'où l'utilisation de "serveur quelconque" )

De ce fait, mon <p> </p> ne rentre plus en compte et je perds ma mise en page (tous mes retours sautent et les éléments se collent l'un l'autre).

Pour palier à cela, j'ouvre mon article sur le serveur en ligne via la console d'édition d'article de joomla (et JCE) et je ne fais que réenregistrer mon article et la l'espacement se retransforme correctement.

Le problème est que si j'ai un site avec 200 articles, ca devient un peu fou de réouvrir et réenregistrer chaque article via la console de joomla.

Je me permets de pauser cette question ici car je n'ai jamais eu de problème avec la console de base de joomla.

Y-a-t-il quelque chose à cocher dans la configuration? Je n'ai pas le goût de forcer des &nbsp; sur tous mes enter.
Dois-je faire une manipulation spéciale lors de mon exportation vers phpMyAdmin ?

(Chose étrange: je ne comprends pas pourquoi les espaces entre les mots fonctionnent et pas celui dans la balise <p> </p> )

Si vous aviez une idée. Merci d'avance.
Dernière édition: il y a 9 ans 11 mois par mfalla.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 9 ans 11 mois - il y a 9 ans 11 mois #2824 par mfalla
Réponse de mfalla sur le sujet exportation db local problème espace balise p
Voici un complément d'informations sur les tests que j'ai effectué.

J'ai réenregistré mon texte dans tinymce et il force des &nbsp; dans les p donc comme ceci <p>&nbsp;</p> au lieu de <p> </p>.

Ce qui évidemment règle le problème.

Cependant après enregistrement d'un texte via JCE, <p> </p> fonctionne dans mon navigateur. Donc ce n'est pas un problème d'affichage de navigateur mais bien un problème d'encodage du caractère " " lors de l'exportation de la db via phpMyAdmin.

Y-a-t-il une solution à cela? Peut-on forcer l'écriture de <p>&nbsp;</p> au lieu de <p> </p> via la console JCE ?

Merci
Dernière édition: il y a 9 ans 11 mois par mfalla.

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 9 ans 11 mois #2828 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet exportation db local problème espace balise p
Hello,
Si tu choisis dans la configuration de JCE -> Nettoyage du code -> Type d'encodage -> "Nommé", tu auras les espaces qui s'afficheront en dur avec le "&nbsp;".
Sinon, effectivement, dans la base de données les espaces entre les paragraphes sont des espaces normaux.
Quand tu sauves ta BD, sauve aussi de manière individuelle la table "content" qui contient les articles.
Ouvre ce fichier avec un traitement de texte et tu fais un "Rechercher/remplacer" de <p> </p> par <p>&nbsp;</p>.
Remplace ensuite sur ton nouveau site le contenu de cette table avec celui que tu as modifié. ;)

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 9 ans 11 mois #2839 par mfalla
Réponse de mfalla sur le sujet exportation db local problème espace balise p
Bonjour et merci pour ta réponse si rapide.

Pour que le formatage nommé fonctionne, je suppose qu'il faut que j'active le nettoyage HTML ?

Qu'est que cela peut entrainer comme conséquences ?

Je l'essayerai lors de mon prochain export de base.

Merci


La deuxième solution est une solution à laquelle j'avais pensé mais il faut avouer qu'elle est un peu longue a exécuter lorsque l'on se retrouve a effectuer souvent des transferts.

Merci encore!

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 9 ans 11 mois #2854 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet exportation db local problème espace balise p
Non, le nettoyage HTML corrige les balises non fermées ou doublées inutilement, il ne va pas interagir avec cette forme d'encodage des espaces.
Par contre cette solution est ok pour de nouveaux contenus ou ceux existant après édition, suffit d'ouvrir et d'enregistrer. Les contenus existants ne vont pas se corriger tout seul dans la base de données.
Tu peux aussi faire un remplacement automatique par une requête SQL directement dans la table de contenu.
Je ne la connais pas par cœur, il te faudrait faire une recherche à ce sujet.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 9 ans 11 mois #2857 par mfalla
Réponse de mfalla sur le sujet exportation db local problème espace balise p
Merci, le Type d'encodage -> "Nommé" fonctionne très bien.
Je vois qu'il pousse les &nbsp; et donc lors de l'exportation-importation via phpmyadmin, tout tient très bien. Et comme je ne tiens pas absolument à ce que cela écrive <p> </p>, c'est tparfait pour moi.

Merci pour ton feedback, je ferai un commentaire positif concernant ton composant ainsi que sur ton aide sur joomla. Si tu veux que j'en dépose autre part, n'hésites pas.

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.151 secondes
Propulsé par Kunena

Rechercher