• Site mis à jour le 03 juin 2019

probleme de style avec Jce et mon fichier css

  • yatoula
  • Portrait de yatoula Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 11 ans 7 mois - il y a 11 ans 7 mois #383 par yatoula
bonjour, déjà je vous conseille de lire ce post qui regroupe une partie du sujet.
Je repose plus rapidement ma question.
J'ai creer dans le CSS de mon template des balises .alert par exemple [code:1].alert {
margin: 10px 0px 10px 0px;
padding: 7px 10px 7px 35px;
border: 1px solid #dcdcdc;
background: #f0f0f0 url(../images/div_alert.png) 3px 3px no-repeat;
text-align:justify;
}[/code:1]

Mon editeur JCE les reconnais dans le style. Mais lorsque j'applique celle-ci à du texte, ca ne fonctionne pas. En regardant le html de l'article je me rends compte que celle ci est interpreté par JCE comme

elle devrait fonctionner theoriquement mais en fait si je remplace span par div ca marche.
Article a voir :
Dernière édition: il y a 11 ans 7 mois par yatoula.

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 11 ans 7 mois #388 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet probleme de style avec Jce et mon fichier css
Salut Yatoula,
Avec l'arrivée des librairies Ajax, Mootools, JQuery et, surtout des normes demandant à faire les templates que par des \"DIV\" (j'aime voir ce que je fais), j'ai un peu abandonné l'idée de les faire entièrement moi-même. Je me suis inscris chez YOOtheme, étudié la façon dont était construit ses templates, et je les adaptes.
La situation est identique avec ces templates. Les \"classes\" \"alert\", \"info\", \"tip\" ou autres, ne fonctionne que s'ils elles sont attribuées à des \"div\" et non des \"span\".
Voir un exemple de description sur ce lien...
Je ne m'y connais pas encore dans la gestion des ces librairies citées plus haut, mais cela a peut-être une incidence.
Je travaille en ce moment sur un apprivoisement de Joomla 1.5, et me relancerai dans les templates après...
Un site réalisé avec joomla! 1.5 RC3 que je vais annoncer tout prochainement, mais je veux encore ajouter quelques éléments...
joomla.sarki.ch .

As-tu vérifié si la situation était la même avec l'éditeur de base de joomla ?
Je pense que ce sera identique, car d'après moi c'est lié à la gestion du template.

Meilleures salutations et bravo pour ton travail !
Mihàly

Connexion ou Créer un compte pour participer à la conversation.

  • yatoula
  • Portrait de yatoula Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 11 ans 7 mois #390 par yatoula
Réponse de yatoula sur le sujet probleme de style avec Jce et mon fichier css
Ben en fait chuis vraiement nul.
Il suffit de mettre que le . devant et c'est pris en charge aussi bien par class que span, des que l'on ajoute devant a la place du point # la balise fonctionne avec les DIV .
D'une maniere ou d'une autre , les class et Div sont tres bien gere par JCE
De plus j'avais fait une boudre avec mes 2 templates similaires, je n'avais que 1 feuille de style pour les 2
Donc ca plus ca plus ca = super mega bug = une nuit blanche et encore pas dormi ...

Connexion ou Créer un compte pour participer à la conversation.

  • yatoula
  • Portrait de yatoula Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 11 ans 7 mois #391 par yatoula
Réponse de yatoula sur le sujet probleme de style avec Jce et mon fichier css
Aussi un truc pour dire que il me faudrait une banniere ou un bouton car mon site cartonne et je recherche des partenaire. Mais pas beaucoup , que des bons et j'ai pensé a toi .
si tu pouvais m'envoyer soit 88x31, 468x60 ou les 2
Merci

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 11 ans 7 mois #392 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet probleme de style avec Jce et mon fichier css
Bon sang de bien sûr... J'avais plus pensé à ça...
Cool d'avoir pensé à moi, je te prépare ces bannières et te les envoie.
Bonne nuit, il parait que quand on a une nuit blanche derrière soit on rêve deux fois plus, alors bon voyages !
Mihàly

Connexion ou Créer un compte pour participer à la conversation.

  • yatoula
  • Portrait de yatoula Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 11 ans 7 mois - il y a 11 ans 7 mois #393 par yatoula
Réponse de yatoula sur le sujet probleme de style avec Jce et mon fichier css
sais pas si je vais bcp dormir ce soir je bosse sur les formulaires et c'est coton pour l'envoi de fichiers..
Mais ca jete avec ChronoForm
Mon formulaire
Dernière édition: il y a 11 ans 7 mois par yatoula.

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.200 secondes
Propulsé par Kunena

Rechercher