• Site mis à jour le 18 janvier 2019

Styles personnalisées dépendant du template

  • FLarsonneur
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 8 ans 3 mois #4106 par FLarsonneur
Styles personnalisées dépendant du template a été créé par FLarsonneur
Bonjour,
Dans les paramètres du composant JCE, il est possible d'utiliser une feuille de styles personnalisée :
templates/$template/css/mafeuilledestyles.css

La variable $template est systématiquement remplacée par le nom de mon modèle par défaut, même quand mon article est affiché avec un autre modèle.

Ai-je oublié quelque chose dans la construction de mes modèles qui expliquerait ce dysfonctionnement ?
Merci d'avance
FLarson.

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 8 ans 3 mois #4111 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet Styles personnalisées dépendant du template
Hello,
Je n'avais plus essayé depuis longtemps, je confirme que cela ne fonctionne toujours qu'avec le template par défaut.
La valeur "$template" ne sert en fait qu'à détecter automatiquement le nom du template appliqué comme celui par défaut.

Connexion ou Créer un compte pour participer à la conversation.

  • FLarsonneur
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 8 ans 3 mois #4115 par FLarsonneur
Réponse de FLarsonneur sur le sujet Styles personnalisées dépendant du template
Merci pour la réponse, même si je comprends bien, mon problème n' a pas de solution simple.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 ans 3 mois #4122 par midgard
Réponse de midgard sur le sujet Styles personnalisées dépendant du template
Bonjour,

Je rencontre également le même problème, systématiquement le $template de la configuration JCE pointe sur le template par défaut. Si on ne gère qu'un template cela ne pose pas de problème. Par contre dans le cas de plusieurs templates, ca revient à laisser l'utilisateur modifier son article avec les couleurs vertes par exemple et à voir le résultat dans des couleurs différentes. Pas simple...
Est-ce un bug (régression récente) ou bien ce fonctionnement a-t-il toujours été celui-ci :
"templates/$template/css/editor_content.css" avec $template pointant non pas vers le template de l'article en cours, mais vers celui par défaut dans joomla ?

La solution de tout mettre dans le template de l'article, pourquoi pas, mais du coup çà affiche plein de feuille de style qui peuvent embrouiller les utilisateurs. La solution de différencier via un éditeur personnalisé dans JCE est une bonne idée à condition que la variable $template renvoi bien vers le modèle en cours... (et pas celui par défaut) :S

En espérant que cela soit un bug provisoire et non le fonctionnement normal.

Merci à Sarki et à tout ceux qui permettent à Joomla d'être cet excellent CMS.
midgard :cheer:

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 8 ans 3 mois #4129 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet Styles personnalisées dépendant du template
Hello,
A ma connaissance, cela a toujours été ainsi, mais n'utilisant pas plusieurs templates avec des styles différents sur un même site, je n'en mettrai pas ma main à couper :)
Il faudrait tenter une recherche sur le forum de Ryan : www.joomlacontenteditor.net/forum/index.php

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.166 secondes
Propulsé par Kunena

Rechercher