• Site mis à jour le 03 juin 2019

[RESOLU] CSS et HTML non pris en compte

Plus d'informations
il y a 8 ans 1 mois - il y a 8 ans 1 mois #4823 par nenex
[RESOLU] CSS et HTML non pris en compte a été créé par nenex
Slt

Dans les articles, en frontend, la mise en forme du code CSS perso n'est pas pris en compte, et chose vraiment zarbi, meme le code HTML :blink: . Je fait mon HTML avec NotePad++ et je le colle dans Joomla. La mise en page dans JCE (donc en backand), elle, est prise en compte.

Sur la page, si je fait un apercu du code source, il y a bien le code HTML, ainsi que mes class et id.

Pour le CSS perso, le fichier typo.css devrait etre bien appele, puisque dans le template.css du template 123wd-j15-6, il y a bien le code :
@import url('typo.css');
Merci d'avance pour votre aide.

Lien vers le site de tests (voir post ci-dessous)
Template : 123wd-j15-6
Joomla 1.5.23
JCE 1.5.7.11

Liens vers les fichiers du template 123wd-j15-6 :
template de base :

Fichier attaché :

Nom du fichier : 123wd_j15_...0501.zip
Taille du ficher :600 ko

Template personnalise :

Fichier attaché :

Nom du fichier : vero_123wd_j15_6.zip
Taille du ficher :248 ko
Pièces jointes :
Dernière édition: il y a 8 ans 1 mois par nenex.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 ans 1 mois - il y a 8 ans 1 mois #4824 par nenex
Réponse de nenex sur le sujet [RESOLU] CSS et HTML non pris en compte
J'ai essaye un truc pour voir. J'ai une installation joomla pour tester des templates ou certain composant. J'ai donc installe le template 123wd-j15-6 personnalise. Le HTML n'etait pas pris en compte. Par contre le CSS oui. Ensuite j'ai installe le meme template, mais celui de base. C'est a dire celui que j'ai telecharge, donc non modifie. Dans le fichier template.css j'ai rajoute la ligne @import url('typo.css'); (qui n'etait pas presente) pour que le fichier css perso soit appele, et la pareil il est bien pris en compte et le HTML toujours pas pris en compte. J'ai mis par default le template Rhuk Milkyway et la le HTML est pris en compte (ainsi que le CSS). Donc ca viendrait du template 123wd-j15-6 personnalise.

J'aimerais savoir comment resoudre ce probleme, car j'ai pas envi de refaire un template.

Dans mon 1e post je rajoute 2 liens vers les fichiers du template 123wd-j15-6 (personnalise et non personnalise). Et je change le lien vers le site de la copine. Je le remplace par celui vers mon installation de tests.
Pièces jointes :
Dernière édition: il y a 8 ans 1 mois par nenex.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 ans 1 mois #4836 par mihaly
Réponse de mihaly sur le sujet [RESOLU] CSS et HTML non pris en compte
Hello,
le lien pour voir le site n'est pas bon, peux-tu le remettre ?

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 ans 1 mois #4837 par nenex
Réponse de nenex sur le sujet [RESOLU] CSS et HTML non pris en compte
Voila c'est fait. Il y avait 2 fois le http: :blink:

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 ans 1 mois #4838 par mihaly
Réponse de mihaly sur le sujet [RESOLU] CSS et HTML non pris en compte
Utilises-tu Firebug pour regarder et contrôler tes classes dans le navigateur ?
Si non, je te le conseille vivement, c'est le meilleur moyen de voir ce qui est vraiment appliqué en frontal et de faire des tests à la volée pour voir que changer.
Sur le lien que tu as mis, je vois que les trois titres ont les même styles : ".date-marche, .date-foire" avec un attribut gras.
La liste à puces a la classe "table.contentpaneopen li" qui est normalement réservée par Joomla pour les listes de catégories d'une section. On voit que "li" n'a pas de marge et "ul" pas de puce, donc normale que ta liste n'apparaît pas.

Quand tu parles de code HTML, que veux-tu dire exactement ?
Est-ce des propriétés de style appliqués à des balises comme par exemple :
<div style"margin:3px 0 5px 0;">blabla</div>

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 ans 1 mois #4840 par nenex
Réponse de nenex sur le sujet [RESOLU] CSS et HTML non pris en compte
Oui j'utilise Firebug. Les titres ont un seul style pourtant. Je met mon code HTML et CSS :

code HTML
<p class="date-marche">titre avec la class date-marche</p>
<p>liste a puce :</p>
<ul>
    <li>Quanta autem vis</li>
    <li>amicitiae sit, ex hoc intellegi</li>
    <li>maxime potest</li>
    <li>quod ex infinita societate</li>
    <li>generis humani, quam conciliavit ipsa natura</li>
</ul>
<p class="date-foire">titre avec la class date-foire</p>
<p>procul a continenti discretam et portuosam inter municipia crebra urbes duae faciunt claram Salamis et Paphus, altera Iovis delubris altera Veneris templo insignis. tanta autem tamque multiplici fertilitate abundat rerum omnium eadem Cyprus ut nullius externi indigens adminiculi indigenis viribus a fundamento ipso carinae ad supremos usque carbasos aedificet onerariam navem omnibusque armamentis instructam mari committat.</p>
<p class="date-foire">titre avec la class date-foire</p>
<p>otiosae sint tribus pacatnaeque <a href="#">lien avec la class lien-ville</a> suffragiorum certamina set Pompiliani redierit securitas temporis, per omnes tamen quotquot sunt partes terrarum, ut domina suscipitur et regina et ubique patrum reverenda cum auctoritate canities populique Romani nomen circumspectum et verecundum.</p>

code CSS (pour cette page) :
.date-marche, .date-foire {font-weight:bold;}
 
.lien-ville a{font-weight:bold;}

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.203 secondes
Propulsé par Kunena

Rechercher