• Site mis à jour le 03 juin 2019

Attribut en trop lors de création de tableau

  • exode785
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 7 ans 9 mois #5363 par exode785
Attribut en trop lors de création de tableau a été créé par exode785
Bonjour,

j'ai un soucis c'est que lorsque je créer des tableaux JCE m'ajoutent plusieurs attributs vide à chaque fois (pas valide W3C car vide).

ex : <td id="" style="width: 13px;" lang="" dir="" scope="" align="" valign="">

Avez vous une solution pour éviter de supprimer manuellement à chaque fois ces attributs.

merci

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 ans 9 mois #5374 par mihaly
Réponse de mihaly sur le sujet Attribut en trop lors de création de tableau
Hello,
Il n'est pas normal que ces attributs soient ajoutés, je viens de faire encore un test.
Peut-être essayé de vider le cache au cas où les scripts appelés ne sont pas les derniers...Quelle est la version de JCE ?

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

  • exode785
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 7 ans 9 mois #5385 par exode785
Réponse de exode785 sur le sujet Attribut en trop lors de création de tableau
Bonjour,

merci de votre aide.

J'ai vider mon cache et j'ai simplement essayé de créer un tableau tout bête :
<table border="0">
<tbody>
<tr>
<td id="" align="" valign="" lang="" dir="" style="width: 12px;" scope="">sdzdzd</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

voilà le code que JCE me génère. En faites dés que je fais propriété d'une cellule pour modifier par exemple la largeur de la cellule, il met par default les autres valeurs.

Merci de votre aide, cdlt.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 ans 9 mois #5445 par mihaly
Réponse de mihaly sur le sujet Attribut en trop lors de création de tableau
Hello,
Je viens d'essayer avec la nouvelle version car le plugin des tableaux a été mis à jour, mais je vois que c'est pareil...
Cela dit, la validation W3C n'est qu'une indication, il y a pas de mal si tu as des valeurs vides.

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

  • exode785
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 7 ans 9 mois #5454 par exode785
Réponse de exode785 sur le sujet Attribut en trop lors de création de tableau
Merci d'avoir pris le temps d'essayer, c'est pas grave pour le W3C. Ca me rassure de ne pas être le seul.

Bonne journée

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.121 secondes
Propulsé par Kunena

Rechercher