• Site mis à jour le 22 mars 2019

[RESOLU] Rajout indésirable de paragraphe avec espace

Plus d'informations
il y a 6 ans 9 mois - il y a 2 ans 10 mois #6762 par nenex
Slt

Je viens de me rendre compte qu'une balise <p>&nbsp;</p> etait rajoute automatiquement apres toutes les balise <p> de mon tableau, apres enregistrement de l'article.

Je cree mon code sous NotePad++ et je fait un copier-coller. Apres l'enregistrement de l'article, <p>&nbsp;</p> est rajoute apres les balises <p> de mon tableau et uniquement dans le tableau.

Codage du tableau fait sous NotePad++ :
 
<table id="tableau-actions">
<tr>
        <td id="titre-date">
			<p>DATES<p>
		</td>
 
		<td id="titre-action">
            <p>ACTIONS<p>
		</td>
 
        <td id="titre-reponses">
            <p>REPONSES / BILANS<p>
		</td>
	</tr>
 
<!-- **************************************************************** -->
 
	<tr>
        <td class="texte-date">
            <p>1 déc 2011<p>
		</td>
 
        <td class="texte-action">
            <p>Assemblée Générale constitutive<p>
		</td>
 
        <td class="texte-reponse">
            <p>74 présents<p>
		</td>
	</tr>
 
<!-- **************************************************************** -->
 
    <tr>
        <td class="texte-date">
            <p>15 déc 2012<p>
		</td>
 
		<td class="texte-action">
            <p>Lettre au maire : demande d’aide pour préparer ce projet<p>
		</td>
 
		<td class="texte-reponse">
            <p>Refus<p>
		</td>
	</tr>
</table>

Le meme code apres l'enregistrement de l'article :
    <tbody>
        <tr>
            <td id="titre-date">
                <p>DATES</p>
                <p>&nbsp;</p>
            </td>
            <td id="titre-action">
                <p>ACTIONS</p>
                <p>&nbsp;</p>
            </td>
            <td id="titre-reponses">
                <p>REPONSES / BILANS</p>
                <p>&nbsp;</p>
            </td>
        </tr>
        <!-- **************************************************************** -->
        <tr>
            <td class="texte-date">
                <p>1 déc 2011</p>
                <p>&nbsp;</p>
            </td>
            <td class="texte-action">
                <p>Assemblée Générale constitutive</p>
                <p>&nbsp;</p>
            </td>
            <td class="texte-reponse">
                <p>74 présents</p>
                <p>&nbsp;</p>
            </td>
        </tr>
        <!-- **************************************************************** -->
        <tr>
            <td class="texte-date">
                <p>15 déc 2012</p>
                <p>&nbsp;</p>
            </td>
            <td class="texte-action">
                <p>Lettre au maire : demande d’aide pour préparer ce projet</p>
                <p>&nbsp;</p>
            </td>
            <td class="texte-reponse">
                <p>Refus</p>
                <p>&nbsp;</p>
            </td>
        </tr>
 

Merci d'avance pour votre aide.

- Joomla 2.5.4
- JCE 2.0.21
- Serveur 2Go 1.8.3
Dernière édition: il y a 2 ans 10 mois par mihaly.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 6 ans 9 mois - il y a 2 ans 10 mois #6763 par nenex
Je me repond a moi meme :P

En virant les balises <p></p> le probleme disparait. Je sais meme pas pourquoi j'ai mis mon texte dans des balises <p></p>... :blink: J'en met jamais dans les tableaux.

Est-ce ca qui pose probleme ? car comme par hasard le probleme disparait quand je vire les balises <p></p>.
Dernière édition: il y a 2 ans 10 mois par mihaly.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 6 ans 9 mois - il y a 2 ans 10 mois #6766 par mihaly
Hello,
Il est possible qu'en ayant la Balise des blocs de contenu ou les nouvelles lignes en paragraphe par défaut dans la config de JCE cela crée cet ajout, probablement qu'en adaptant cette config l'ajout ne serait plus là, mais je n'ai pas testé :)

Mihàly Marti alias Sarki
Dernière édition: il y a 2 ans 10 mois par mihaly.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 6 ans 9 mois - il y a 2 ans 10 mois #6768 par nenex
Merci pour ta reponse.

Je vais m'auto-flageler :P. Je viens de me rendre compte que les balises <p> ne sont pas fermees... :blush:

Je les ai toute fermees et ca ne rajoute plus aucune ligne. En fait a la base c'etait que des balises <p> et je voulais transformer en tableau. Le code que j'ai mis en exemple c'est juste une petite partie du code complet. Pour me simplifier j'ai fait du remplacer par avec NotePad++, mais je me suis plante :lol: .

Donc voila la reponse a mon probleme.
Dernière édition: il y a 2 ans 10 mois par mihaly.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 6 ans 9 mois - il y a 2 ans 10 mois #6769 par mihaly
Ok, ça nous arrive à tous :P
Merci du retour et bon week-end :)

Mihàly Marti alias Sarki
Dernière édition: il y a 2 ans 10 mois par mihaly.

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.171 secondes
Propulsé par Kunena

Rechercher