• Site mis à jour le 22 mars 2019

Problème avec le texte justifié [OK]

  • Zwitefli
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 6 ans 8 mois - il y a 6 ans 6 mois #6895 par Zwitefli
Problème avec le texte justifié [OK] a été créé par Zwitefli
Bonjour,
Ayant installé l'extension JCE Editor sur mon site ( www.madeinlens.com ), je connais quelques problèmes depuis la dernière mise à jour.
En effet, j'utilise la dernière version de Chrome (j'ai essayé aussi sous Firefox 13.0.1 et j'ai le même souci) et, quand je justifie un texte dans l'éditeur, cela ajoute automatiquement plusieurs lignes au début du texte. Voici le code qui apparaît en affichant le code source :

style="text-align: justify;">&nbsp;</p>
<p style="text-align: justify;">&nbsp;</p>
<p style="text-align: justify;">&nbsp;</p>


Et cela provoque un décalage de trois-quatre lignes dans les articles publiés sur le site, et ajoute des lignes en fin de message. En éditant la news (ou en affichant le code source puis en supprimant les lignes créées), le problème disparaît mais cela reste très gênant. De plus, lorsqu'une image est ajoutée à l'article, il est impossible de supprimer l'ensemble des lignes blanches : il faut en laisser une, sinon l'article s'affiche mal.
Avec les précédentes versions de JCE Editor, je n'avais pas ce problème sous Chrome, mais je l'avais sous Firefox. J'ai désinstallé puis réinstallé l'extension, mais cela n'a rien corrigé.
Dans l'attente de vos conseils et en espérant que cela vous permettra d'améliorer encore votre excellente extension.
Dernière édition: il y a 6 ans 6 mois par mihaly.

Connexion ou Créer un compte pour participer à la conversation.

  • Zwitefli
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 6 ans 8 mois - il y a 6 ans 8 mois #6897 par Zwitefli
Réponse de Zwitefli sur le sujet Problème avec le texte justifié [OK]
Je me permets d'ajouter un second message, si cela peut vous être utile.
Sur la version de test du site, j'utilise la version 2.2.1 de JCE et je n'ai aucun souci, que ce soit avec IE9 ou les dernières versions de Chrome et Firefox. J'ai créé plusieurs articles sans rencontrer le moindre souci.
Après update avec la version 2.2.1.2 de JCE Editor, je rencontre le même problème que celui évoqué dans mon premier message.

Edit : sur le site, j'ai désinstallé complètement JCE puis réinstallé la version 2.2.1.1. Le problème reste présent. Toutefois, j'ai remarqué que ce souci n'est présent que si j'utilise le "Lire la suite". Si l'article est court et ne nécessite pas l'ajout de la fonction "Lire la suite", je n'ai pas de ligne qui s'ajoute si je justifie le texte.
Dernière édition: il y a 6 ans 8 mois par Zwitefli.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 6 ans 8 mois #6908 par mihaly
Réponse de mihaly sur le sujet Problème avec le texte justifié [OK]
Hello,
J'ai constaté également ce problème dans certains cas, et l'ai réglé en modifiant les nouvelles lignes par défaut (balise paragraphe ou div) dans la configuration générale de JCE.
Cette fonction a évolué dans les dernières versions 2.2.1.1 et .2 qui hérite de celle adaptée dans TinyMCE qui est le tronc de JCE.
Il va donc falloir attendre un peu que cela soit corrigé dans TinyMCE.

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

  • Zwitefli
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 6 ans 8 mois #6916 par Zwitefli
Réponse de Zwitefli sur le sujet Problème avec le texte justifié [OK]
OK, merci de votre message.
J'espère donc que la prochaine mise à jour règlera le problème. ;)
D'ici là, j'utiliserai le TinyMCe que j'ai remis par défaut sur mon compte et avec lequel, pour l'instant, je n'ai pas de bug. ;)

Connexion ou Créer un compte pour participer à la conversation.

  • Zwitefli
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 6 ans 8 mois #6934 par Zwitefli
Réponse de Zwitefli sur le sujet Problème avec le texte justifié [OK]
Mise à jour en 2.2.2 installée... mais rien n'est résolu. C'est même pire ;) Avant, justifier le texte ajoutait systématiquement 3 lignes blanches. Là, j'en ai désormais 6 ! ;)
Je suis repassé sous l'éditeur TinyMCE en attendant. Et là, aucun souci. ;)

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 6 ans 8 mois #6948 par mihaly
Réponse de mihaly sur le sujet Problème avec le texte justifié [OK]
Hello,
Je viens de tester avec la version 2.2.3 et ne rencontre aucun problème.
Je mets le pack FR encore aujourd'hui, il faudra installer le dernier pack de langue FR si vous faites la mise à jour en ligne.

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.169 secondes
Propulsé par Kunena

Rechercher