• Site mis à jour le 16 août 2019

[RESOLU] <u></u> se transforme en <span style="...</span>

Plus d'informations
il y a 6 ans 9 mois - il y a 6 ans 8 mois #7482 par nenex
Slt

Il m'arrive un truc assez curieux avec la balise <u></u>. En effet, quant je copie le code de article, avec dedans une balise <u></u>, et que je le sauvegarde la balise <u></u> se transforme en <span style="text-decoration: underline;"></span> :blink: . Ca ne le fait pas avec les balises <strong></strong> presente. J'ai insere une balise <i></i> et elle ne se transforme pas.

(bout du code avec la balise <u></u>)


<div id="important">
<p>IMPORTANT</p>
<p><u>Juillet/Août</u> : essayez d'appeler en dehors des horaires mentionnés, car en fonction de la demande, les plages horaires sont susceptibles d'être agrandies.</p>
</div>

<div id="important">
<p>IMPORTANT</p>
<p><span style="text-decoration: underline;">Juillet/Août</span> : essayez d'appeler en dehors des horaires mentionnés, car en fonction de la demande, les plages horaires sont susceptibles d'être agrandies.</p>
</div>


Je ne vois pas d'ou ca peut venir.

Merci d'avance pour votre aide.

- Joomla 2.5.8
- JCE 2.2.9.1
- En local avec Serveur 2Go 1.8.3d
Dernière édition: il y a 6 ans 8 mois par nenex.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 6 ans 9 mois #7485 par mihaly
Salut,
As-tu essayé les différents réglages de la partie "Nettoyage & Sortie"de la configuration de JCE qui se retrouve également en partie dans les profils JCE sous "Paramètres de l'éditeur" ?

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 6 ans 9 mois - il y a 6 ans 9 mois #7492 par nenex
Merci pour ta reponse.

Petite precision (que je viens de remarquer) : j'ai meme pas besoin de sauvegarder l'article pour que le changement se fasse. Rien que le fait de masquer/afficher le code me remplace la balise <u></u>.

sinon, dans Nettoyage & Sortie des parametre generaux :

- Validation HTML est sur Non (j'ai essaye avec Oui mais ca change rien).
- Type de validation est sur HTML4 (j'ai essaye avec HTML5 mais ca change rien).
- Type d'encodage est sur UTF-8.
- Compatibilité Plug-in est sur Non.

Et dans les parametre de l'editeur du profil admin, les reglages de la validation et du type d'encodage sont sur Herite.
Dernière édition: il y a 6 ans 9 mois par nenex.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 6 ans 8 mois #7506 par mihaly
Après une petite recherche sur le web, j'ai vu que la balise <u> n'est pas valide en strict xhtml, c'est certainement pour cela qu'elle est transformée avec une propriété de style dans une balise span.

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 6 ans 8 mois #7513 par nenex
alors je vais laisser le span. C'est pas genant a partir du momment que je le sais qu'il ne faut pas mettre la balise <u>.

Merci pour ton aide.

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.167 secondes
Propulsé par Kunena

Rechercher