• Site mis à jour le 22 mars 2019

le style css n'apparait pas dans JCE

  • eva
  • Portrait de eva Auteur du sujet
  • Hors Ligne
  • Rédacteur Occasionnel
  • Rédacteur Occasionnel
Plus d'informations
il y a 6 ans 3 mois #7653 par eva
le style css n'apparait pas dans JCE a été créé par eva
bonjour Sarki

j'ai un petit problème avec JCE. je lui ai attribué un fichier CSS rien que pour lui et tout et tout et il le voit : j'ai bien la liste des classes CSS de mon fichier JCE.css dans la liste déroulante des styles de mon éditeur préfèré ; mais le problème c'est qu'à l'affichage dans la fenêtre de mon éditeur côté back-end je ne vois aucun des styles que j'ai défini ( mes h1 sont écris en gris et je ne le vois pas, les H2 ont une puce latérale qui n'apparait pas, les <ul> sont décalées vers la droite te ça ne se voit pas non plus...)
bref ça marche en front mais pas dans JCE...
une idée stp ?

A bientôt
Eviouchka

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 6 ans 3 mois #7659 par mihaly
Réponse de mihaly sur le sujet le style css n'apparait pas dans JCE
Hello Eviouchka,
As-tu le même problème dans l'éditeur en front ?
Je n'ai pas très bien compris si c'est ok uniquement dans l'affichage normal ou également en édition.
Je serai surpris que le comportement soit différent dans l'éditeur en utilisant le même profil en front et en admin, mais j'ai déjà eu des surprises :)
De ce que tu dis, il semblerait que le CSS chargé dans l'éditeur en admin ne soit pas le fichier jce.css, ou en tout cas pas uniquement.

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

  • eva
  • Portrait de eva Auteur du sujet
  • Hors Ligne
  • Rédacteur Occasionnel
  • Rédacteur Occasionnel
Plus d'informations
il y a 6 ans 3 mois #7668 par eva
Réponse de eva sur le sujet le style css n'apparait pas dans JCE
Hi Sarki !

:huh: euh...en fait sur ce site_là je n'édite pas en front à la demande du client et donc je n'ai pas essayé.
Dans l'affichage de mon article en front, le style rangé dans JCE.css est bien appliqué pas de soucis, c'est quand j'édite l'article en back-end que le style n'apparait pas dans l'éditeur et c'est gênant, ce n'est pas WYSIWYG.
je te joins des captures d'écran de la vue front d'un article et de la vue back du même article dans l'éditeur JCE, ainsi qu'une capture de la configuration de JCE au cas où le pb viendrait de là.

merci de ton aide rapide Mihaly.
a bientôt

Connexion ou Créer un compte pour participer à la conversation.

  • eva
  • Portrait de eva Auteur du sujet
  • Hors Ligne
  • Rédacteur Occasionnel
  • Rédacteur Occasionnel
Plus d'informations
il y a 6 ans 3 mois #7688 par eva
Réponse de eva sur le sujet le style css n'apparait pas dans JCE
Hi Sarki!

je viens aux nouvelles ; j'ai pas mal cherché sur le net mais je ne trouve rien qui m'aide sur ce pb : as-tu une idée d'une direction dans laquelle chercher ? j'ai constaté que , dans sa liste déroulante, JCE lit bien les styles du fichier JCE.CSS que j'ai créé mais quand je regarde avec firebug , je vois que JCE ne prends pas en compte ces styles-là à l'affichage mais qu'il va chercher son css par défaut dans \components\com_jce\editor\tiny_mce\themes\advanced\skins\default\content.css...
est-ce qu'il n'y aurait pas un bug possible avce le framework Gantry que j'utilise ou bien parce que c'est un multisite ?
je continue a chercher de mon côté.

A+

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 6 ans 3 mois - il y a 6 ans 3 mois #7689 par mihaly
Réponse de mihaly sur le sujet le style css n'apparait pas dans JCE
Hello Eva,
Les captures dont tu parlais dans ton précédent message n'ont malheureusement pas passé, peut-être trop grandes.

Le chargement du fichier content.css de JCE montre en effet que celui du fichier jce.css ne se fait pas.
Il faudrait voir comment tu appelles ce fichier, et vérifier que si tu le fait dans la configuration de JCE, celui-ci ne soit pas supplanté par un autre appel spécifié dans ton profil.
Si l'appel d'un CSS doit se faire pour tous les profils, il vaut mieux l'appliquer dans la configuration.

Peux-tu faire une capture d'écran des paramètres de l'appel du CSS dans la configuration de JCE ? Cela me permettra de voir ce qui est appelé ou devrait l'être.

Je ne sais pas comment tu appelles ce fichier dans ton template, ou si tu as intégré ses valeurs dans un autre CSS.
Si c'est le cas, cela expliquerait que les styles soient visibles en affichage frontal, qu'il puissent l'être dans la liste déroulante chargeant le css par défaut du template, mais pas dans la zone de l'éditeur.

Mihàly Marti alias Sarki
Dernière édition: il y a 6 ans 3 mois par mihaly.

Connexion ou Créer un compte pour participer à la conversation.

  • eva
  • Portrait de eva Auteur du sujet
  • Hors Ligne
  • Rédacteur Occasionnel
  • Rédacteur Occasionnel
Plus d'informations
il y a 6 ans 3 mois - il y a 6 ans 3 mois #7690 par eva
Réponse de eva sur le sujet le style css n'apparait pas dans JCE
Sarki

merci beaucoup de ton aide et de ta diligence. Mes copies d'écran ne passant pas, je t'envoie l'URL du site en prod pour que tu puisses tout regarder par toi-même ça ira plus vite . Les styles pris en compte dans le fichier JCE.CSS ne sont inscrits nulle part ailleurs .il y a bien un nouveau profil dans jce qui se nomme "SCD" alors peut-être que c'est là qu'est le problème mais il fait appel au même fichier css .
fais très attention s'il-te-plait c'est un vrai site en ligne !

je t'envoie par mail sur ta boite info l'url et les identifiants.


a bientôt et merci
Dernière édition: il y a 6 ans 3 mois par eva.

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.119 secondes
Propulsé par Kunena

Rechercher