• Site mis à jour le 03 juin 2019

Problème de l'editeur de liens en front-end

  • ml44230
  • Auteur du sujet
  • Hors Ligne
  • Rédacteur Régulier
  • Rédacteur Régulier
Plus d'informations
il y a 6 ans 3 mois - il y a 6 ans 2 mois #7988 par ml44230
Bonjour,
Je suis sous Joomla 2.5.9 et JCE 2.3.1.
Lorsque, dans JCE, je veux mettre un lien sur un texte d'un article et que ce lien se rapporte à une entrée du menu principal, tout se passe très bien en back-end (via l'interface d'administration du site). Un clic sur 'menu principal dans l'éditeur de liens de JCE affiche les entrée du menu et je peux choisir le lien de menu désiré.
J'ai défini un utilisateur en tant que rédacteur. Lorsque je veux, en Front-end, faire la même opération, il se produit une boucle dans l'éditeur de lien de JCE lorsque je clique sur 'Menu Principal' et les entrées du menu principal ne s'affichent pas.
L'utilisateur rédacteur est bien connecté et possède les droits sur les articles et les liens de menu concernés.
Quelqu'un aurait-il une solution ?
Merci d'avance à tous !
Michel
Dernière édition: il y a 6 ans 2 mois par mihaly.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 6 ans 3 mois #8001 par mihaly
Réponse de mihaly sur le sujet Problème de l'editeur de liens en front-end
Hello Michel,
Ton problème est uniquement avec ce groupe JCE, tu as vérifié ?

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

  • ml44230
  • Auteur du sujet
  • Hors Ligne
  • Rédacteur Régulier
  • Rédacteur Régulier
Plus d'informations
il y a 6 ans 3 mois #8010 par ml44230
Réponse de ml44230 sur le sujet Problème de l'editeur de liens en front-end
Bonjour Mihàli,
Merci pour ta réponse.
Dans le panneau d'administration de JCE, j'ai bien active le profil JCE front end, mais le problème demeure.
En fait lorsque je veux ajouter un lien sur un objet en Front end, j'ai bien accès aux liens vers les articles (toutes catégories), contacts, etc, il n'ya que sur Menu où ça coince Quand je clique sur Menu, la fénêtre s'ouvre en me laissant le choix entre Menu Principal et Menu Kunena (intégré au site) . Si je clique sur Menu Principal, il se produit une boucle comme si on n'arrivait pas à afficher les entrées de ce menu.
En back end, tout marche normalement
Merci pour ton aide, je n'y comprends rien !
Michel

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 6 ans 3 mois #8015 par mihaly
Réponse de mihaly sur le sujet Problème de l'editeur de liens en front-end
Le profil JCE frontend ne sera utilisé que par les groupes qui lui sont liés, si tu te connectes en frontal avec un groupe de niveau supérieur, c'est le profil correspondant qui sera utilisé, dans l'ordre d'affichage des profils si le groupe est dans deux profils.

Ce que je voulais dire avant, c'est que si tu es connecté en frontal avec un profil JCE dont l'accès aux liens est interdit dans ses paramètres, il est normal que tu ne puisses y accéder.
Il peut arriver également que si tu es connecté avec un groupe Joomla qui n'a pas accès à un de ces liens, cela tourne en boucle.

Par contre, si tu es connecté en frontal avec le même profil JCE qu'en administration, et que cela ne fonctionne pas pareil, c'est que tu as un conflit JavaScript avec un élément chargé dans la page en frontal (module, plugin ou autre).

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

  • ml44230
  • Auteur du sujet
  • Hors Ligne
  • Rédacteur Régulier
  • Rédacteur Régulier
Plus d'informations
il y a 6 ans 3 mois #8020 par ml44230
Réponse de ml44230 sur le sujet Problème de l'editeur de liens en front-end
Bonjour Mihaly,
Merci beaucoup pour tes explications qui m'ont mis sur la voie et m'ont permis de clarifier mon problème.
Je ne pense pas d'ailleurs que JCE soit impacté, il s'agit plutôt pour moi d'un problème lié aux ACL de Joomla.
Voici la situation clarifiée :
J'ai défini sur mon site (en local pour l'instant), un groupe d'utilisateurs "Choisis" et un nouveau niveau d'accès "Restreint" (Groupe Parent : "Public".
Le groupe d'uilisateurs "Choisis" a l'autorisation sur le niveau d'accès "Restreint"
Le menu principal possède des entrées ayant un niveau d'accès "Public" et des entrées avec un niveau d'accès "Restreint". Certains articles possèdent aussi le niveau d'accès "Restreint".
Tout fonctionne très bien, seuls les utilisateurs du groupe "Choisis" voient les entrées de menu ou les articles ayant le niveau d'accès "Restreint", c'est ce que je voulais obtenir.
L'administrateur en backend est défini comme super utilisateur et, dans le gestionnaire de liens JCE, peut affecter à un objet un lien vers n'importe quelle entrée du menu principal.
Je définis un nouvel utilisateur dans le groupe "Editeur" et je le mets dans le profil JCE front End, activé.
Connecté au site en frontal, celui-ci ne voit que les entrées du menu ayant l'accès "Public" ce qui est normal, et, dans le gestionnaire de liens JCE ne peut mettre que des liens sur les entrées de niveau d'accès "Public".
Tout fonctionne normalement, il n'y a pas de boucle dans le gestionnaire de liens JCE en voulant ouvrir les entrées sur le menu principal.
Maintenant, si j'autorise le groupe "Editeur" sur le niveau d'accès "Restreint", l'utilisateur du groupe Editeur voit le menu principal avec toutes les entrées. Normal encore.
Par contre, s'il veut mettre un lien sur un objet vers une entrée du menu principal, il se produit une boucle dans le gestionnaire de liens JCE en voulant ouvrir les entrée du menu principal, problème qui a occasionné ma demande d'aide !
Voilà, si tu as une idée, je suis preneur car je ne sais pas quoi faire.
Dans les paramètres des droits au niveau des menus ou des modules, j'ai laissé les valeurs par défaut pour les différents groupes (Hérité).
Merci d'avance pour votre patience à lire l'exposé de mon problème et pour vos conseils.
Michel

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 6 ans 3 mois #8035 par mihaly
Réponse de mihaly sur le sujet Problème de l'editeur de liens en front-end
Hello Michel,
Pas eu l'occasion de revenir sur ce forum cette dernière semaine...
Le long résumé est super, il me permet de bien comprendre le problème.
Je vais essayer de trouver un moment pour le reproduire e5t voir si je trouve une parade, sinon j'ajouterai ce problème dans les bugs à corriger.

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.176 secondes
Propulsé par Kunena

Rechercher