• Site mis à jour le 18 janvier 2019

Relation Contenu - Cible

Plus d'informations
il y a 4 ans 2 mois - il y a 4 ans 2 mois #10037 par mtjoom
Relation Contenu - Cible a été créé par mtjoom
Bonjour

Je développe un module d'affichage de liens dans une lightbox modal.

Voila mon problème:
Je renseigne le champ "Relation Contenu - Cible" dans l'onglet "Avancé" avec la ligne:
{handler:"iframe", iframeOptions: {scrolling:"no"}, size: {x: 900, y: 500}}

Lorsque je mets à jour la première fois, la ligne est transformée comme suit:
{handler:"iframe", iframeOptions: {scrolling:"no"}, size: {x: 900, y: 500}}

Lorsque je mets à jour la seconde fois, la ligne est transformée comme suit:
{handler:"iframe", iframeOptions: {scrolling:"no"}, size: {x: 900, y: 500}}

Lorsque je mets à jour la troisième fois, la ligne est transformée comme suit:
{handler:"iframe", iframeOptions: {scrolling:"no"}, size: {x: 900, y: 500}}

Donc à chaque mise à jour du lien un "amp;" vient s'ajouter au code, entre le "&" et le "quot;".


J'ai testé avec différents:
navigateurs: Opera, FF32, IE8-9
OS: XP SP2 et SP3, Windows7.

J'ai tenté de remplacer les doubles quotes par des simples, mettre le code html des simples et doubles quotes.

Le problème reste constant.

Si je supprime les simples ou doubles quotes le lien ne fonctionne plus....

Avez-vous déjà vu ce problème?, si oui avez-vous une solution ou une idée sur l'origine du problème?.

Je penche pour un souci avec le code de JCE.

Merci.
Dernière édition: il y a 4 ans 2 mois par mtjoom.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 4 ans 2 mois #10038 par mihaly
Réponse de mihaly sur le sujet Relation Contenu - Cible
Hello,
Il te faut vérifier dans le profil JCE utilisé si les iframes sont autorisées, ainsi que l'insertion de JavaScript.
Normalement, si tu restes en affichage code au moment de l'enregistrement, il ne devrait pas y avoir de changement, s'il y en a c'est qu'un de ces deux éléments n'est pas autorisé.

Mihàly Marti alias Sarki
Les utilisateur(s) suivant ont remercié: mtjoom

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 4 ans 2 mois - il y a 4 ans 2 mois #10039 par mtjoom
Réponse de mtjoom sur le sujet Relation Contenu - Cible
Merci de ta réponse mihaly,

Le fait est que c'est le simple fait de faire la mise à jour du lien qui modifie le texte renseigné dans le champ "Relation Contenu - Cible".

Enregistrement ou pas de l'article, cela ne change rien.

Quand à passer en affichage code, je ne voit plus l'intérêt de JCE qui facilite la création des liens pour les personnes utilisant le "WYSIWYG".

Pour ce qui est des iframes et javascript, elles sont autorisées et cela fonctionne si j'inscrit le lien soit en dur dans le code soit en réinscrivant à chaque mise à jour, la ligne:
{handler:"iframe", iframeOptions: {scrolling:"no"}, size: {x: 900, y: 500}}
Pas très pratique pour l'utilisateur lambda ...

Avez-vous déjà entendu parler d'un problème similaire?

Merci

PS: peut-être quelqu'un ayant une connaissance du code de JCE, pourrait me renseigner de l'endroit ou la correction du texte se fait...

Cordialement.
Dernière édition: il y a 4 ans 2 mois par mtjoom.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 4 ans 2 mois #10040 par mihaly
Réponse de mihaly sur le sujet Relation Contenu - Cible
Comme je l'ai dit, je te suggérais de passer en mode code pour voir si c'était à l'enregistrement qu'il y avait un nettoyage, je ne te disais pas de travailler dans ce mode. Évidemment, si tu dis que ce n'est pas à l'enregistrement que le code se modifie, cela n'a pas d'importance.
Au vu de tes précisions, n'ayant jamais rencontré ce cas ni eu de remontée dans ce forum à son sujet, je te suggère de le présenter directement sur le forum de l'auteur, tu auras plus de chance d'avoir une solution.

Mihàly Marti alias Sarki
Les utilisateur(s) suivant ont remercié: mtjoom

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 4 ans 2 mois #10041 par mtjoom
Réponse de mtjoom sur le sujet Relation Contenu - Cible
Merci de tes conseils et informations, me voilà déjà fixé.
Pour ce qui est de travailler en code, c'est ce que je fais à longueur de journée pour que les utilisateurs n'aient pas à le faire. :)

Je vais suivre ton conseil et aller poster sur le site de l'auteur, et reviendrait pour informer de la solution, si elle existe.

Cordialement.

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.126 secondes
Propulsé par Kunena

Rechercher