• Site mis à jour le 22 mars 2019

Images invisibles en vue complète des articles

  • georgie
  • Portrait de georgie Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 3 ans 11 mois - il y a 3 ans 11 mois #10490 par georgie
Bonjour à tous

J'ai un problème avec les images insérées avec JCE dans les vues complètes des articles (pas dans les vue Intro).

Je précise que j'utilise un template très joli, très design et responsive, bref très moderne, mais peut-être un peu complexe... Avec notamment des classes CSS qui semblent se mettre automatiquement dans les images.

Ça marche bien avec les images insérées avec le composants de base de Joomla, mais moins bien avec JCE.

C'est triste car JCE est bien le meilleur éditeur, j'aurais du mal à m'en passer juste pour pouvoir profiter d'un beau template...

Quelqu'un a-t-il déjà observé ce problème avec des templates récents (Joomla 3.1.4, la toute dernière version) ?

Un exemple ici : ohm-estarreja.in2p3.fr/

L'article placé tout en bas de la page d'accueil s'affiche bien en intro ("Sortie du film La lagune et l'usine"), mais cliquez sur le titre et l'image disparaît, avec un affreux bloc vide à la place...

### Triste...
### JCE
Dernière édition: il y a 3 ans 11 mois par mihaly. Raison: Résolu

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 ans 11 mois #10499 par mihaly
Réponse de mihaly sur le sujet Images invisibles en vue complète des articles
Hello,
Je vois que tu utilises le script Lazyload qui charge les images que lorsque l'on est au-dessus dans la page, les classes ajoutées sont pour cela.
C'est un script sympa surtout lorsqu'il y a beaucoup d'images dans une page et qu'on la consulte avec une connexion mobile et un quota de chargement limité, mais j'ai constaté des conflits avec les popups JCE MediaBox, par contre pas sur le simple affichage d'une image.
Si tu as installé toi-même un plugin qui charge ce script, essaie en le désactivant. C'est peut-être ton template qui a installé ce plugin ou qui le charge autrement, regarde si tu as un paramètre à ce sujet dans sa config.
Redis-moi si cela résout ton problème ;)

Mihàly Marti alias Sarki
Les utilisateur(s) suivant ont remercié: georgie

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 ans 11 mois #10500 par mihaly
Réponse de mihaly sur le sujet Images invisibles en vue complète des articles
Note: on voit dans le code que c'est un gif transparent qui est chargé à la place de l'image et qu'il vient de ce plugin : /plugins/system/tmlazyload/blank.gif

Mihàly Marti alias Sarki
Les utilisateur(s) suivant ont remercié: georgie

Connexion ou Créer un compte pour participer à la conversation.

  • georgie
  • Portrait de georgie Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 3 ans 11 mois #10503 par georgie
Réponse de georgie sur le sujet Images invisibles en vue complète des articles
Merci des conseils !

En fait ce script est installé par défaut dans le template en question.
Et le template ne possède pas d'option pour l'activer/désactiver.

Ça doit bien être possible de le désactiver, par contre je ne souhaiterais pas le désactiver complètement, car il est très pratique notamment dans les galeries photos, que j'utilise.

À votre avis, serait-il possible de le désactiver uniquement dans les articles en vue complète ?

Connexion ou Créer un compte pour participer à la conversation.

  • georgie
  • Portrait de georgie Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 3 ans 11 mois - il y a 3 ans 11 mois #10504 par georgie
Réponse de georgie sur le sujet Images invisibles en vue complète des articles
Oh ! Ça semble être résolu, grâce à votre dernier message !

Comme effectivement c'est un plugin à part entière dans l'admin de Joomla, j'ai été voir, et il a des options pour le désactiver sur certains composants.

Je l'ai donc désactivé sur "com_content", et je n'ai plus ce problème (il semble que je le perde tout de même sur certains types d'affichages que j'avais utilisé, via des articles, mais pas sur les galeries photos).

Que pensez-vous de cette façon de faire ?

Grand merci !!!
Dernière édition: il y a 3 ans 11 mois par georgie.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 ans 11 mois #10505 par mihaly
Réponse de mihaly sur le sujet Images invisibles en vue complète des articles
Hello,
Super, c'est bien que ce plugin propose ces choix.
En effet, en désactivant "com_content" il ne sera plus chargé dans les articles mais persistera dans les autres composants dont celui des galeries photo, une bonne solution ;)

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.133 secondes
Propulsé par Kunena

Rechercher