• Site mis à jour le 22 mars 2019

Gestionnaire de liens : Les menus ne se déploient plus

  • grainesdeweb
  • Portrait de grainesdeweb Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 2 ans 1 mois #11529 par grainesdeweb
Bonjour,

C'est la 1ère fois que je suis confronté à ce souci depuis que j'utilise JCE (quelques années ;) )

Depuis hier, les menus ne se déploient plus dans le gestionnaire de liens JCE. :(
J'ai la version 2.6.8 traduite en Fr et lorsque je clique sur le + d'un lien de menu principal dans l'éditeur (ex : main menu), rien se déploie, aucun liens de sous-menu alors qu'ils sont nombreux.



Avez-vous déjà été confronté à cet ennui ? Auriez-vous une idée ou une solution ?

Merci bcp d'avance
Bonne journée à tous

Philippe
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 1 mois #11530 par mihaly
Hello Philippe,
Avec le passage vers JCE 2.6.x il y a eu de nombreux changements/mises à jour de scripts.
Dans ces cas, il faut veiller à vider le cache du navigateur, et à désactiver toutes compressions JavaScripts et Gzip avant de les réactiver si souhaités.
Il faut regarder pour cela dans la config JCE pour la compression JavaScript, puis dans la config Joomla pour la Gzip, et parfois dans certaines config de template ou de plugin spécifiques pour "accélérer" le site.

Mihàly Marti alias Sarki
Les utilisateur(s) suivant ont remercié: grainesdeweb

Connexion ou Créer un compte pour participer à la conversation.

  • grainesdeweb
  • Portrait de grainesdeweb Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 2 ans 1 mois #11532 par grainesdeweb
Réponse de grainesdeweb sur le sujet Gestionnaire de liens : Les menus ne se déploient plus
Merci pour tes conseils Mihaly, je les ai appliqué à la lettre...mais cela n'a malheureusement rien changé..:(

J'ai vidé le cache Joomla, puis le cache effectivement présent dans dans les réglages de la template, j'avais même installé admin tools pour vider fréquemment le répertoire temporaire, et enfin j'ai vidé le cache de mon navigateur (et ai même essayé plusieurs navigateur), rien n'y fait.

Aucune compression Gzip activée ni dans Joomla, ni dans la template, ni la compression JS & CSS dans les réglages de cette même template (JV Framework).

Je gère plusieurs sites Joomla, ils sont presque tous chez le même hébergeur et la dernière mise à jour de JCE a été appliquée sur quasi l'ensemble de ces sites sans avoir jamais rencontré ce "pépin" technique.
Je reste vraiment dubitatif...

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 1 mois #11533 par mihaly
Hello,
Tu as également regardé la compression JS & CSS dans la config JCE car tu n'en parles pas ?

Si ce n'est pas ça, alors c'est peut-être un problème avec les profils.
Suivant de quand date l'installation première de JCE, il est possible de se retrouver avec des profils pas 100% compatibles avec le passage vers la version 2.6.x.
Dans ce cas, il faut supprimer tous les profils ce qui redirige sur le panneau de contrôle dans lequel un lien apparaît permettant de recréer les profils. Il faut tous les supprimer, car sinon les nouveaux profils ne sont pas créés selon les nouveaux modèles.
Quand tu les a tous supprimer, tu peux également importer le profil "Administrateur" que j'ai mis à disposition ici : sarki.ch/jce/kunena/problemes-divers/9538-profils-jce
Il y en a un pour la version Core et un pour la version Pro.
Ces profils n'ont rien de particulier, perso je n'aime pas l'organisation par défaut des icônes, alors pour éviter de devoir toujours tout réorganiser j'ai l'habitude d'importer ce profil.

Et si ce n'est pas un problème avec le profil alors je ne vois pas de quoi cela peut venir...
Un conflit avec une autre extension ou la version PHP de ton serveur ou un autre réglage ?
Si tu veux tu peux me créer un compte provisoire que je puisse aller y jeter un œil, peut-être qu'en faisant le tour des éléments l'illumination me gagnera :)

Mihàly Marti alias Sarki
Les utilisateur(s) suivant ont remercié: grainesdeweb

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.160 secondes
Propulsé par Kunena

Rechercher