• Site mis à jour le 03 juin 2019

PDF : textes et photos faits avec JCE mal encodés

  • lliseil
  • Portrait de lliseil Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 11 ans 3 semaines #1170 par lliseil
Salut,
Avec J1.5.3, VM1.1, JCE1.5, les articles écrits sous JCE passent mal lors génération PDF sur le frontend : les accents et les photos ne passent pas.

Le texte et les photos générés hors JCE (par VM) passent bien.
-> Je trouve pas de réglages dans JCE.
-> Pour VM j'ai passé l'encodage en UTF-8 (réglage dans les fichiers et encodage des fichiers, avec utrac).
-> Dans PHPMyAdmin toutes les tables sans exception sont en "utf8_general_ci"

Ex (texte) :

• Consommation : 7 litres aux 100 km
• Année : 1997
• Couleur : gris métal
• Kilométrage : 287000 kms
Toutes options :
cuir, clim auto bi-zone, 4 vitres électriques, jantes alus, sià ̈ges électriques à mémoire

Ex (images) inserées avec JCE1.5 :

Photos
ï¿1⁄2ï¿1⁄2ï¿1⁄2type=image,ypos=30,width=39.675,height=29.624ï¿1⁄2ï¿1⁄2ï¿1⁄2q 112.46 0 0 83.97 28.35 222.03 cm /I2

Pour info la sortie d'un 'grep ISO' sur VirtueMart 1.1/administrator/components/com_virtuemart/ :
CHANGELOG.php:
+ introduced a new function called "vmGetCharset" to return the current charset from the _ISO setting (UTF-8 by default), ps_main.php
classes/ps_main.php:
* Returns the charset string from the global _ISO constant
html/shop.pdf_output.php:
<meta http-equiv="Content-Type" content="text/html; '. _ISO.'" />

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 11 ans 3 semaines #1173 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet PDF : textes et photos faits avec JCE mal encodés
Merci pour ces infos.
Je vais tester cette semaine, je dois justement installer un VM sur une version 1.5.3.
Te redis ce qu'il en est de mon côté.

Connexion ou Créer un compte pour participer à la conversation.

  • lliseil
  • Portrait de lliseil Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 11 ans 3 semaines #1182 par lliseil
Réponse de lliseil sur le sujet PDF : textes et photos faits avec JCE mal encodés
mihaly je vois pas d'où vient le soucis.
Oui ce serait intéressant de comparer avec un système propre et/ou installé sur un autre système.
Ici le site (en local mais plus très longtemps...) est sous le pinguoin, et j'ai passé tout (normalement) VM en UTF-8.

Pas trouvé de post sur joomlafacile traitant de soucis entre JCE 1.5 et la génération PDF sous Joomal 1.5
Pour info j'ai posté là : forum.joomlafacile.com/showthread.php?t=65052

ps : merci pour ta doc JCE mise en ligne après le JoomlaDay, elle est excellente :)

Connexion ou Créer un compte pour participer à la conversation.

  • lliseil
  • Portrait de lliseil Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 11 ans 2 semaines #1199 par lliseil
Réponse de lliseil sur le sujet PDF : textes et photos faits avec JCE mal encodés
mihaly > as-tu jetté un oeil sur l'export PDF d'articles écris avec JCE depuis stp ?

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 11 ans 2 semaines #1204 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet PDF : textes et photos faits avec JCE mal encodés
Hello lliseil,
Pas encore, ai dû m'occuper de la dernière version de JCE. Ferai à ce propos un mailing ce soir.
Je te tiens au courant...

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 11 ans 2 semaines #1216 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet PDF : textes et photos faits avec JCE mal encodés
Bhou... encore une mise à jour, je m'en doutais car il y avait de nombreux bugs, que j'avais en bonne partie corrigé et communiqué.
Bon je viens de finir le composant, verrai demain le plugin et ses extensions.
Au sujet des PDF j'ai vérifié sur des articles écrits avec JCE mais en dehors de VM. Aucun souci ave les accents ou les images. Pour VM il faut que je trouve encore le temps cette semaine d'installer une version sur un site en construction.
Te redis

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.156 secondes
Propulsé par Kunena

Rechercher