• Site mis à jour le 03 juin 2019

pb pour insérer des images

  • Cobayecrau
  • Auteur du sujet
  • Visiteur
  • Visiteur
il y a 11 ans 2 mois #922 par Cobayecrau
pb pour insérer des images a été créé par Cobayecrau
Bonjour,
J'ai Joomla 1.5.2 et JCE 1.5.0 en localhost

Lorsque j'essaye d'insérer des images avec le gestionnaire d'images 1.5.0, je rencontre des problèmes pour uploader des images de mon disque dur vers un des dossiers visibles dans l'arborescence.

Je clique sur la petite icone transférer sur la droite, une fenêtre de recherche s'ouvre on peut bien sélectionner les images voulues, très bien jusque là.
l'upload semble bien se faire les coches passent au vert, mais les images n'arrivent nulle part et surtout pas dans le répertoire courant.

Bref, comment faut il faire pour uploader des images d'un emplacement quelconque vers le répertoire accessible au gestionnaire d'image.

J'espère avvoit été clair ?:S

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 11 ans 2 mois #923 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet pb pour insérer des images
Oui, d'ailleurs ta procédure est juste.
Je pense que cela vient du fait que tu es en localhost, donc les images sont propablement envoyées dans le disque virtuelle créé par ton serveur autonome. Au fait, lequel utilises-tu ?
En ligne, je ne rencontre pas de problèmes.

Connexion ou Créer un compte pour participer à la conversation.

  • cobayecrau
  • Auteur du sujet
  • Visiteur
  • Visiteur
il y a 11 ans 2 mois #924 par cobayecrau
Réponse de cobayecrau sur le sujet pb pour insérer des images
Merci,
Hélas je ne comprends pas bien la réponse, pourquoi j'irai sur un disque virtuel ?
Cela ne transfère pas d'un répertoire X vers le répetoire sur lequel on pointe avec le gestionnaire d'image ?.

Pour ajouter encore quelques détails, lorsque je transfère par copier coller du répertoire ou se situent mes images vers le répetoire stories etc.... ou je veux mettre mes images, les images ne sont pas visibles par le gestionnaire d'image (alrs qu'elles le sont par l'explorateur windows).
J'ai l'impression d'être bloqué à treize images par répertoire, bizarre.

Je veux bien que cela marche quand on n'est pas en localhost, mais j'espérais pouvoir utiliser cet éditeur pour mettre à jour tous mes articles Joomla avec des photos avant de mettre en ligne cette nouvelle version de mon site. C'est quand même mieux de travailler tranquille chez soi sans perturber le site de production.

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 11 ans 2 mois #925 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet pb pour insérer des images
Personnellement je ne développe pas de site en local.
Les contenus je ne dis pas, mais les composants, nombreux sont ceux qui ont besoin de droits particuliers sur des répertoires/dossiers ou fichiers. En local pas de problèmes, les droits sont complets.
Mais quand on envoie un site en FTP sur le serveur, ces répertoires/dossiers ou fichiers se mettent en écriture (CHMOD) par défaut. Souvent 664 pour les fichiers et 755 pour les dossiers. Ces droits ne correspondent pas forcément à ceux qui auraient étés attribués par une installation sur le serveur distant...
Pour répondre à ton problème...
Quand tu lance un serveur virtuel (tu ne m'as pas dit lequel tu utilises), pour faire fonctionner la fonction http:// permettant d'appeler une adresse web, il crée un disque virtuel temporaire, souvent nommé 'W'
Du coup, quand tu travailles par le site, les fichiers uplodés se mettent dans le répertoire de ce disque.
En principe, quand tu désactives le serveur virtuel, les dossiers se mettent à jour.
Selon ce principe, il est évident que si tu colles par l'explorateur windows des images dans le répertoire de base alors que le site est lancé par le serveur virtuel, tu ne les verras pas par JCE, ni par autre chose d'ailleurs...
Voilà, j'espère avoir été plus clair, sinon il te faut revoir les bases des serveurs par le forum Joomlafacile .
A+

Connexion ou Créer un compte pour participer à la conversation.

  • cobayecrau
  • Auteur du sujet
  • Visiteur
  • Visiteur
il y a 11 ans 2 mois #926 par cobayecrau
Réponse de cobayecrau sur le sujet pb pour insérer des images
Bonjour,
Oups, j'utilise XAMPP.
OK, je suis d'accord pour le disque virtuel, mais à priori c'est temporaire, surtout quand on utilise la fonction transfert puis upload d'image gallerie.
sinon cela veux dire qu'on ne peut faire de transfert et upload qu'au sein du serveur.
D'ailleurs, un arrêt/relance du serveur apache ne consolide pas la situation.
De plus j'ai l'impression que je reste bloqué à 13 fichiers, bizarre, pas de barre d'ascenceur disponible pour visualiser plus bas.
Pourquoi aussi je n'ai accès qu'au dossier racine stories (qui apparait avec le libellé chemin) et aux dossiers en dessous food et fruit (plus celui que j'ai ajouté).
Cela serait sympa d'avoir la même visibilité (ou mieux) qu'avec le gestionnaire de média de Joomla.

Pour les CHMOD, je connais le problème, mais il est facile à résoudre lors des transferts FTP des composants, ou bien sur le serveur lui même (si on a les droits, c'est le pb des serveurs mutualisés). Et ce n'est pas le problème ici.

Bref cela reste un grand mystère qui limite l'utilisation que je peux faire de ce produit (mon problème serai-il lié au fait que j'utilise la version gratuite ?)

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 11 ans 2 mois #930 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet pb pour insérer des images
Hello,
Pour savoir de quoi je parle et profitant d'une mise à jour, je viens d'insatller Movamp pour tester en local.
Je lance le serveur, me connecte, et envoie d'un coup 10 images sans problèmes. Depuis impossible d'envoyer à nouveau une image... :blink:
Par contre, les images ont bien été mises à jour en temps réél sur les deux espaces.
Ce n'est pas la première fois qu'il est question de problèmes en local, des messages avaient déjà été écrits à ce sujet sur la version pour Joomla! 1.0.x. Mais elles avaient été résolues avec les mises à jour.
De toute façon, nous ne sommes pas encore en version stable, donc à toi de voir si tu trouves mieux, quitte à changer plus tard.
Une chose est sûr, rien à voir avec le fait que c'est la version gratuite :)
Pour le chemin des dossiers: configuration du plugin ImageManager et de l'explorateur JCE

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.161 secondes
Propulsé par Kunena

Rechercher