• Site mis à jour le 18 janvier 2019

Affectation des profils à des groupes

  • Patrick.R
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 2 ans 6 mois #11179 par Patrick.R
Affectation des profils à des groupes a été créé par Patrick.R
Bonjour Sarki,
J'ai une difficulté de configuration de JCE
Version JCE 2.4.6 sous Joomla 2.5.28
Hormis le public, les adhérents et les responsables, j'ai deux groupes d'utilisateurs pouvant créer des articles.

- Les "Webmasters" qui appartiennent au groupe "éditeurs", avec accès au backoffice, ne peuvent déposer des fichiers que dans "images/stories/REGIONS/" (qui doit donc être la racine pour eux).
Pour eux, j'ai créé un profil JCE "Webmasters".

- Les administrateurs peuvent déposer dans "images/stories/" (qui doit donc être la racine pour eux).
Pour eux, j'ai créé un profil JCE "Administrateurs".

Je n'arrive pas à affecter correctement ces profils aux groupes de Joomla. Tous ont la limitation du profil Webmasters, c'est-à-dire sur "images/stories/REGIONS/"

Je dois mal faire un paramétrage, mais je ne parviens pas à trouver où…

Note : je configure ainsi l'accès dans le paramétrage du profil :
Profil "Administrateurs"
Paramétres de l'éditeur
Fichiers systémes
Chemin du répertoire principal pour le groupe "administrateurs" :
images/stories/

Merci de ton aide.

Patrick R.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 6 mois #11180 par mihaly
Réponse de mihaly sur le sujet Affectation des profils à des groupes
Hello Patrick,
Je viens de faire des tests avec le groupe "administrator" par défaut de Joomla que j'ai dirigé sur un sous-dossier de "images", puis avec le groupe éditeur par défaut de Joomla que j'ai dirigé sur un sous-sous-dossier de "images" histoire de suivre ton architecture de dossiers, tout est ok de mon côté.
Tu est bien en édition de profil dans le premier onglet "Généralités" sous "Groupe d'utilisateurs" quand tu coches ton groupe Joomla ?
Tu es sûr que dans ce paramètres tu as bien uniquement le groupe "éditeurs" de Joomla qui est coché dans le profil JCE "Webmasters" et le groupe "administrateurs" de Joomla dans le profil JCE "Administrateurs" ?
Et tu es sûr que des deux utilisateurs Joomla que tu utilises pour tes tests il y en a bien un dans le groupe "Webmasters" et un dans le groupe "administrateurs" ?
Une dernière chose est l'ordre de tes profils JCE, essaie si jamais de les intervertir dans la liste des profils.

Ce qui me surprend toutefois dans ce que tu dis est que le groupe "éditeurs" ait un accès au backoffice, si tu n'as pas changé les accès par défaut de Joomla ce groupe n'y a pas accès.

Mihàly Marti alias Sarki
Les utilisateur(s) suivant ont remercié: Patrick.R

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 6 mois #11181 par mihaly
Réponse de mihaly sur le sujet Affectation des profils à des groupes
Ah une dernière chose, y a-t-il une raison pour que tu sois en version 2.4.6 de JCE et non pas sur la dernière à disposition soit la 2.5.19 ?
Si tu es toujours en version Joomla 2.5.28 est-ce par ce que tu as des problèmes d'incompatibilité pour passer sur Joomla 3.x ?

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

  • Patrick.R
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 2 ans 6 mois #11183 par Patrick.R
Réponse de Patrick.R sur le sujet Affectation des profils à des groupes

mihaly écrit: Hello Patrick,


Hello Mihaly

Je viens de faire des tests avec le groupe "administrator" par défaut de Joomla que j'ai dirigé sur un sous-dossier de "images", puis avec le groupe éditeur par défaut de Joomla que j'ai dirigé sur un sous-sous-dossier de "images" histoire de suivre ton architecture de dossiers, tout est ok de mon côté.
Tu est bien en édition de profil dans le premier onglet "Généralités" sous "Groupe d'utilisateurs" quand tu coches ton groupe Joomla ?.

Oui, exactement

Tu es sûr que dans ce paramètres tu as bien uniquement le groupe "éditeurs" de Joomla qui est coché dans le profil JCE "Webmasters" et le groupe "administrateurs" de Joomla dans le profil JCE "Administrateurs" ?

Oui, un seul groupe coché pour chacun des profils

Et tu es sûr que des deux utilisateurs Joomla que tu utilises pour tes tests il y en a bien un dans le groupe "Webmasters" et un dans le groupe "administrateurs" ?.

Oui, un seul groupe pour chacun de mes utilisateurs de test et ceux-la

Une dernière chose est l'ordre de tes profils JCE, essaie si jamais de les intervertir dans la liste des profils.

J'ai 3 profils : Administrateurs, Default, Webmasters, dans cet aborde après avoir changé l'ordre.
Curieusement, je n'arrive pas à placer le profil "Default" pour aucun groupe d'utilisateurs. Même après enregistrement, les affectations restent activées.

Ce qui me surprend toutefois dans ce que tu dis est que le groupe "éditeurs" ait un accès au backoffice, si tu n'as pas changé les accès par défaut de Joomla ce groupe n'y a pas accès.

J'ai changé les accès par défaut. J'ai un peu galère pour organiser les droits...

Patrick R.

Connexion ou Créer un compte pour participer à la conversation.

  • Patrick.R
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 2 ans 6 mois #11184 par Patrick.R
Réponse de Patrick.R sur le sujet Affectation des profils à des groupes

mihaly écrit: Ah une dernière chose, y a-t-il une raison pour que tu sois en version 2.4.6 de JCE et non pas sur la dernière à disposition soit la 2.5.19 ?

Non, pas vraiment, je vais faire la mise à jour de JCE

Si tu es toujours en version Joomla 2.5.28 est-ce par ce que tu as des problèmes d'incompatibilité pour passer sur Joomla 3.x ?

Il y a un template particulier et je préférerai essayer d'abord sur une version de test. Surtout qu'il s'agit d'un changement de version majeure...

Merci Milahy,

Patrick R.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 6 mois #11185 par mihaly
Réponse de mihaly sur le sujet Affectation des profils à des groupes
Hello Patrick,
Ok, essaie en effet déjà en mettant à jour JCE, cela est peut-être simplement lié à cette ancienne version, bien que j'en doute un peu.
Autrement tu as l'air d'avoir tout fait correct donc pas de raison que cela ne fonctionne pas.
Il y a juste le comportement bizarre du profil JCE Default qui me surprend...
Je n'ai pas très bien compris, tu dis que tu n'arrives pas à lui attribuer des groupes différents de ceux qui sont déjà coché c'est ça ? Et les groupes "éditeur" et "administrator" y sont cochés ? Normalement "administrateur" devrait l'être par défaut, mais si tu n'as pas mis le même chemin dans ce profil que dans le profil "Webmasters" il n'y a pas de raison que le groupe "administrateur" en hérite...
Pourrais-tu me créer un compte provisoire que je puisse accéder à l'admin pour voir si je repère ce qui cloche ? Tu peux m'envoyer les accès par le formulaire de ce site, je suis le seul à le recevoir ;)

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.156 secondes
Propulsé par Kunena

Rechercher