• Site mis à jour le 18 janvier 2019

Version 2.6.1

  • viti69
  • Auteur du sujet
  • Hors Ligne
  • Rédacteur Occasionnel
  • Rédacteur Occasionnel
Plus d'informations
il y a 2 ans 1 mois - il y a 2 ans 1 mois #11382 par viti69
Version 2.6.1 a été créé par viti69
Bonjour,

J'ai un soucis de lien depuis le chargement de l'extension 2.6.1
Avant j'avais la version 2.5.31
Depuis que j'ai chargé la version 2.6.1, plus aucun lien ne fonctionne hors ceux du menu principal.
Avant j'avais par exemple .../index.php?option=com_content&view=article&id=63&Itemid=175
maintenant j'ai .../index.php/produits/tuteurs et la page recherchée ne peut s'afficher ( + message404 )

Comment faire pour corriger tous mes liens
Merci
Dernière édition: il y a 2 ans 1 mois par mihaly. Raison: Ajout icône Attention

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 1 mois #11389 par mihaly
Réponse de mihaly sur le sujet Version 2.6.1
Hello,
Si j'étais toi, je commencerais par remettre la version 2.5.31 de JCE que tu peux télécharger sur ce site : www.sarki.ch/jce/telecharger

Attention, tu ne peux pas réinstaller simplement par dessus, tu dois d'abord désinstaller la version 2.6.1 en désinstallant le pack JCE et non seulement le composant comme c'était le cas avant. En effet la version 2.6.x s'installe maintenant à l'aide d'un pack.

Dis-moi ensuite comment tu as fait tes liens, il n'est pas normal que tu aies ce résultat, il faut que je puisse essayer de reproduire.
Ce sont des liens fait avec le gestionnaire de liens de JCE ?
Ce sont des liens vers des articles ou des liens de menu ?
Essaie de me donner le max d'info ;)

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

  • viti69
  • Auteur du sujet
  • Hors Ligne
  • Rédacteur Occasionnel
  • Rédacteur Occasionnel
Plus d'informations
il y a 2 ans 1 mois #11395 par viti69
Réponse de viti69 sur le sujet Version 2.6.1
Merci
Dimanche j'ai chargé le pack pro 2.6.1 en espérant que mes soucis de liens allez disparaître mais cela n'a pas été le cas alors, j'ai refait une bonne partie de liens pour que mon site fonctionne un peu mieux dés cette semaine.
exemple de liens mis en place
technissage.fr/index.php?option=com_content&view=article&id=19&Itemid=135
exemple de lien avant :
technissage.fr/index.php/fiches/272-fiche-bois-rondino-14

Je suis peut être encore allez trop vite maintenant, je me demande si je remet la version 2.5.31, les nouveaux liens marchent plus.
Ton avis
Merci

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 1 mois #11398 par mihaly
Réponse de mihaly sur le sujet Version 2.6.1
Hello,
Non, dans ce cas ne reviens pas en arrière, il vaut mieux que tu ailles de l'avant.
Pour que je comprenne mieux, peux-tu me dire si c'est un site que tu as migré de différentes versions de Joomla, qui par exemple était initialement en 1.5 ou 1.6, 2.5 ou 3.x, car il y a eu des changements dans la gestion des urls au fil des versions.
C'est donc des liens dans des contenus puisque tu dis que le menu principal lui fonctionne ? Ce qui est normal puisque que le menu principal est fait avec le gestionnaire de menu de Joomla et non avec JCE.
Comment faisais-tu ces liens ?
C'était des liens vers des articles de Joomla ?
Avais-tu des liens vers des liens de menu ? Et si oui ceux-ci ont-ils eu aussi des problèmes ?

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

  • viti69
  • Auteur du sujet
  • Hors Ligne
  • Rédacteur Occasionnel
  • Rédacteur Occasionnel
Plus d'informations
il y a 2 ans 1 mois #11401 par viti69
Réponse de viti69 sur le sujet Version 2.6.1
Merci pour ton aide
Oui je suis parti d'une premier version Joomla - celle qui existait fin 2014 - puis j'ai fait régulièrement chaque mise à jour Joomla.

Pour faire mes liens:
Soit après avoir créé un article, j’ajoute dans le menu un lien dans « Menus: Tous les liens de menu » ainsi mon article s’affiche dans mon site à l’endroit où se trouve le menu
Je cliquant sur l’article et je le copie sur une autre page ou je souhaite faire ouvrir ce liens.
Soit je vais dans « Articles : Modifier » je clique sur l’icone « inserer/modifier un lien » et je clique sur l’article que je souhaite – c’est la que j’ai ce type de lien (index.php?option=com_content&view=article&id=2:concept&catid=21:titre-concept&Itemid=108)

Cordialement

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 1 mois #11405 par mihaly
Réponse de mihaly sur le sujet Version 2.6.1
Bon, j'espère que tu vas avoir le courage de lire jusqu'au bout, je t'explique des choses importantes à mon sens ;)

J'ai fait des tests avec une ancienne version et une actuelle, les liens créés depuis le gestionnaire de liens de JCE sont les mêmes entre ces différentes versions, si tu as eu un problème la cause est ailleurs...

Voici à quoi ressemble un lien vers un article fait avec le gestionnaire de liens de JCE :
index.php?option=com_content&view=article&id=1:test&catid=2:non-categorise&Itemid=101
Lien vers un lien de menu affichant ce même article :
index.php?option=com_content&view=article&id=1&Itemid=162

Les liens que tu dis avoir eu avant et plus maintenant sont pourtant bien les liens qui sont toujours fournis par JCE.
Tu dis que tu as maintenant :
index.php/produits/tuteurs et la page recherchée ne peut s'afficher ( + message404 )
Ce n'est pas possible, c'est un lien avec le SEF partiel de Joomla activé, c'est à dire c'est ce que tu vois dans la barre d'adresse du navigateur et non pas dans le gestionnaire de liens de JCE, et je ne comprends pas où tu vois le message : la page recherchée ne peut s'afficher ( + message404 )

J'ai l'impression que tu ne saisis pas très bien la différence entre les liens de menu de Joomla et le liens fait avec le gestionnaire de liens de JCE, ainsi que les notions de SEF qui permet d'avoir des URL en clair tel
www.mon-site/ma-page/
au lieu d'avoir des URL de construction de page telle
  • "index.php?option=com_content&view=article&id=1&Itemid=162"
    Par exemple, cette URL non SEF de construction de page nous indique les éléments suivants :
    il s'agit d'un lien vers un contenu utilisant le composant d'articles (com_content), affichant l'article ayant l'id 1, et le lien de menu a l'id 162
  • Le lien suivant est un lien vers le blog des articles mis en vedette, et le lien de menu a l'id 163 :
    index.php?option=com_content&view=featured&Itemid=163
  • Le lien suivant est un lien vers une liste d'articles d'une catégorie ayant l'id 12, et le lien de menu a l'id 164
    index.php?option=com_content&view=category&id=12&Itemid=164
Cette architecture permet de comprendre ce qui est affiché, mais utiliser ce genre d'URL n'est pas idéal pour des raisons de sécurité car cela permet au hacker de comprendre ce qui est affiché et donc de savoir comment tenter le piratage, et pour des raisons de référencement.

Joomla propose un SEF partiel qui laisse index.php dans les URL, et un SEF complet.
Si dans la configuration globale de Joomla tu actives le SEF complet, alors tu n'as plus index.php dans l'URL, et les liens dans les pages ne seront plus des liens de type "construction de page" mais de type SEF, c'est conseillé notamment pour le référencement ;)

Maintenant, un autre conseil important...
Avec le gestionnaire de JCE ne fais jamais des liens vers des articles mais vers des liens de menu Joomla !
C'est très important car cela te permet non seulement de pouvoir gérer les modules affichés avec le contenu central, mais aussi de conserver des liens valides même si tu changes la cible de ton lien de menu vers une autre page, ou que tu renommes le lien ou la page vers laquelle le lien dirige. Cela est possible puisque Joomla gère les liens avec les id des éléments et non avec leur nom.

Je t'avoue que j'ai lu au moins 5 fois ton dernier message mais je n'arrive toujours pas à comprendre comment tu fais tes liens...
J'essaie de résumer...
  • Tu as créé un menu dans Joomla nommé "Tous les liens de menu" dans lequel tu as fait un lien vers chaque article. Ceci est très bien car cela te permet ensuite de faire, comme je l'ai dis, des liens vers ces liens de menu et non vers les articles.
  • Par contre, je ne comprends pas ce que tu dis là : "ainsi mon article s’affiche dans mon site à l’endroit où se trouve le menu". L'article s'affiche avec le menu uniquement si tu as un module de type "Menu" qui est lié au lien de menu, c'est à dire qu'il est dit au module d'apparaître au moment où on clique sur ce lien de menu, sinon ces deux éléments n'ont pas de raison de s'afficher ensemble.
  • Tu dis également : "Soit je vais dans « Articles : Modifier » je clique sur l’icone « insérer/modifier un lien » et je clique sur l’article que je souhaite". Comme je viens de le dire plus haut, fais des liens vers les liens de menu et non vers les articles.

En conclusion je ne saurai dire d'où est venu ton problème puisque les URL n'ont pas changé depuis les versions 2014 de Joomla. Mais ce que je peux te dire c'est que si tu prends l'habitude de faire un lien de menu Joomla pour chaque élément dont tu as besoin d'un lien dans un contenu, et qu'ensuite dans ces contenus tu fais des liens vers ces liens de menu et non vers les articles, alors, que tu renommes ou non un article ou un lien de menu, que tu actives ou non le SEF partiel ou complet de Joomla, tes liens seront toujours valides :)

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.129 secondes
Propulsé par Kunena

Rechercher