• Site mis à jour le 22 mars 2019

problème d'accents sur fenêtres popup

Plus d'informations
il y a 10 ans 1 mois #2617 par yza
Hello,

Voilà je précise de suite que je suis novice avec Joomla, le code html et tout le toutim.. j'ai installé JCE et j'ai un souci : les caractères accentués ne sortent pas bien sur les fenêtres pop-up de l'éditeur comme par exemple éditer une image. C'est excactement ce qui est représenté sur ce fil :
www.sarki.ch/jce/index.php/problemes-divers/1500-reprobleme-accents-da...netres-jce.html#1500

Sauf que, dans mon cas je ne suis pas en local, j'ai testé avec 3 navigateur (firefox 3, epiphany et opera), en mettant bien utf-8 sur chaque navigateur et j'ai toujours pas le bon affichage...


Je précise que ça ne le fait que sur les fenêtres pop-up...

Donc en un mot : help !

D'avance merci :)

Nb : juste pour info, quand je fait une recherche sur le forum, impossible d'accèder aux pages suivantes (?)

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 10 ans 1 mois - il y a 10 ans 1 mois #2618 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet problème d'accents sur fenêtres popup
Hello,
Deux éléments peuvent faire que les caractères spéciaux ne soient pas pris en compte correctement :

1. La base de données n'est pas en utf8_general_ci comme ci-dessous...



2. L'appel de la norme d'encodage n'est pas la bonne dans le template.
Si l'appel suivant est présent entre les balises <head> et </head>, le supprimer !
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
Rechercher la balise suivante avant l'ouverture <head>...
<html xmlns="http://www.w3.org/1999/xhtml">
et la remplacer ou l'ajouter si inexistante par...
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="<?php echo $this->language; ?>" lang="<?php echo $this->language; ?>" dir="<?php echo $this->direction; ?>" >
Redis-moi si jamais...
Pièces jointes :
Dernière édition: il y a 10 ans 1 mois par YRrT_mihaly.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 10 ans 1 mois #2623 par yza
Réponse de yza sur le sujet problème d'accents sur fenêtres popup
Merci pour cette prompte réponse :)

- Alors, pour le 1) c'est bon la base est bien en UTF8_general_ci
- pour le 2)...euh je ne suis pas sûre du template à vérifier ...Khepri je suppose, mais je ne suis pas sûre, en tous cas lui, il a tout bon sur le code. Mais peut-être est-ce un autre template à véirifier ? Je le suppose car les caractères accentués ne sont mal gérés que sur les pop-up à l'intérieur de l'éditeur (article existant ou nouveau)... sinon c'est bon partout ailleurs.

Pourrais-tu m'indiquer précisemment le fichier à vérifier ?

Encore merci.

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 10 ans 1 mois #2624 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet problème d'accents sur fenêtres popup
Quand tu parles du template Khepri, cela veut dire que ton problème est identique en backend ? Si c'est le cas, alors cela ne vient pas du template.
La différence entre l'affichage de la page et le popup d'outils, c'est que ce dernier n'est pas influencé par la langue du navigateur.
Théoriquement, ce dernier devrait s'afficher en mode UTF8. Pour vérifier, il faut cliquer dans l'éditeur et vérifier son encodage.

Je mets à disposition la dernière version de JCE en FR.
Le composant 1.5.1 et le plugin 1.5.2.
Je les mets en version beta car je n'ai pas tout corrigé pour le FR et je dois préciser qu'il faut tout désinstaller avant d'installer cette nouvelle version.
En effet, de nombreux changements ont été fait sur le processus d'installation, la gestion des groupes et, un des plugins.
Essaie éventuellement avec cette version et redis moi.
Pour l'instant je la mets uniquement sur le site www.sarki.ch/jce15 sans faire de pub.
Redis-moi.
Sarki

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 10 ans 1 mois #2626 par yza
Réponse de yza sur le sujet problème d'accents sur fenêtres popup
Il y a du mieux : les pop-up tableaux, caractères spéciaux, et apparement tous les autres s'affichent bien ...excepté le gestionnaire d'images. Je ne sais pas si ça t'aides mais moi je trouve que c'est déjà pas mal.

Connexion ou Créer un compte pour participer à la conversation.

  • YRrT_mihaly
  • Visiteur
  • Visiteur
il y a 10 ans 1 mois - il y a 10 ans 1 mois #2630 par YRrT_mihaly
Réponse de YRrT_mihaly sur le sujet problème d'accents sur fenêtres popup
Vous n'êtes pas nombreux à rencontrer ce problème, je ne comprends pas vraiment de quoi cela peut venir.
Je vais regarder où se situent ces éléments de traductions et, au pire, je proposerai le ou les fichiers à remplacer que j'aurai adapter en encodage ANSI.
A+
Dernière édition: il y a 10 ans 1 mois par YRrT_mihaly.

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.199 secondes
Propulsé par Kunena

Rechercher