• Site mis à jour le 03 juin 2019

Difficulté pour modifier taille et couleur d'un texte

  • ml44230
  • Auteur du sujet
  • Hors Ligne
  • Rédacteur Régulier
  • Rédacteur Régulier
Plus d'informations
il y a 3 ans 3 mois #11099 par ml44230
Bonjour,
Il me semble que depuis JCE 2.5.14, j'ai un problème pour modifier la taille et la couleur du teste dans un nouvel article.
Voilà ce qui se passe :
1 - Je crée un texte dans un nouvel article.
Je modifie la taille et la couleur du texte de la 1ère ligne en mettant taille 14 pt et couleur rouge (avec l'outil "appliquer une couleur au texte" de la barre d'outils JCE).
Sur mon écran, le texte concerné apparaît correctement Voir image_1 en pièce jointe.
2 - Si je bascule l'éditeur pour voir le code HTML, je ne retrouve pas les balises "color" et font-size" dans la balise "style =" qui a été générée. Après sauvegarde de mon article, la 1ère ligne apparait en noir et de taille d'origine. La modification n'a pas été prise en compte. Voir image_2 en pièce jointe.
3 - Maintenant, après la sauvegarde, je modifie à nouveau la taille et la couleur du teste de la 1ère ligne pour remettre en 14 pt et rouge. Je bascule l'éditeur en mode HTML et, cette fois, les balises "color" et ""font-size" sont correctement positionnées. Voir image_3 en pièce jointe.
Après sauvegarde, l'article apparaît correctement en front end.
Il ne me semble pas que je devais modifier 2 fois et faire une sauvegarde intermédiaire auparavant.
Quelqu'un a-t'il une idée ou solution ?
Merci d'avance pour votre aide.
Michel
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 ans 1 mois #11134 par mihaly
Hello,
je ne sais pas si ton problème s'est résolu mais pour ma part je ne l'ai jamais rencontré.
Encore une fois, ce genre de bug est soit dû à un conflit de script, soit à un chargement non abouti de la page, toutefois si le problème est systématique alors c'est un conflit.

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

  • ml44230
  • Auteur du sujet
  • Hors Ligne
  • Rédacteur Régulier
  • Rédacteur Régulier
Plus d'informations
il y a 3 ans 1 mois #11136 par ml44230
Bonjour Mihaly,
Merci pour ta réponse !
Mon problème n'est toujours pas résolu et est systématique : je ne peux modifier qu'un seul critère de police à la fois dans un texte et je dois faire "Enregistrer" pour faire une autre modification.
Par exemple, pour changer la police, la taille du texte et la couleur du texte sur une phrase d'un article, je dois faire :
changer la police => Enregistrer l'article
Changer la taille => Enregistrer
Changer la couleur => Enregistrer
Alors que normalement, je pouvais faire ces 3 changements à la fois.
S'il s'agit d'un conflit de script comme tu dis, comment puis-je savoir d'où provient ce conflit ?
Merci de ton aide !
Michel

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 ans 1 mois #11139 par mihaly
Hello Michel,
As-tu déjà essayé de désinstaller et de réinstaller JCE ?
Si tu as la compression/optimisation JavaScript voir même CSS activée dans la configuration de JCE ou dans celle de Joomla ou encore d'une autre extension tel le template (lequel utilises-tu ?) cela pourrait en être la raison.
En tout cas une chose est sûr c'est qu'il y a un problème JavaScript.
Si ce n'est pas une compression/optimisation activée qq part, alors c'est comme je le disais un conflit. Dans la gestion des extensions tu peux dépublier toutes les extensions, en désactivant les extensions tierces une à une cela permet de trouver laquelle est en conflit. Sinon, il faut voir par le navigateur ou des outils web ajoutés, les conflits JavaScript peuvent être affichés, cela permet en général de savoir quelles sont les extensions concernées.

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

  • ml44230
  • Auteur du sujet
  • Hors Ligne
  • Rédacteur Régulier
  • Rédacteur Régulier
Plus d'informations
il y a 3 ans 1 mois #11143 par ml44230
Merci beaucoup pour tes conseils Mihaly :)
Je n'ai pas de compression JavaScript ou CSS et j'utilise le template Protostar de Joomla 3.5.1
Sur tes conseils, j'ai fait quelques essais :
1 - J'ai désinstallé tous les composants de JCE et j'ai installé JCE 2.4.6 disponible en téléchargement sur le site de JCE francophone.
Et là, plus de problème pour effectuer d'un coup plusieurs modifications de style sur une partie du texte d'un article. Tout fonctionne correctement.
2- J'ai ensuite installé la mise à jour pour passer en JCE 2.5.16
Et là, je retrouve les mêmes problèmes que j'ai signalés dans mes posts précédents.
Je suis donc repassé en JCE 2.4.6 sans chercher plus loin pour l'instant d'où provient le blocage de Javascript.
Je suis à ta disposition pour continuer les tests si tu le désires .
Y a t-il un inconvénient à rester en JCE 2.4.6 ?
Bien cordialement
Michel

Je suis donc

Connexion ou Créer un compte pour participer à la conversation.

  • ml44230
  • Auteur du sujet
  • Hors Ligne
  • Rédacteur Régulier
  • Rédacteur Régulier
Plus d'informations
il y a 3 ans 1 mois #11144 par ml44230
Je me réponds à moi-même sur les inconvénients à rester en JCE 2.4.6 :
Cette version ne fonctionne pas avec PHP 7.0.
Sur un de mes sites hébergé sur un serveur avec PHP 7.0, j'ai dû revenir en PHP 5.6 pour pouvoir créer un nouvel article avec JCE.
Ma solution de passer à JCE 2.4.6 pour corriger les blocages de JavaScript n'est donc pas pérenne :(
Il va donc falloir aller plus loin ;)
cordialement
Michel

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.830 secondes
Propulsé par Kunena

Rechercher