• Site mis à jour le 22 mars 2019

MediaBox sous JCE

  • placJCE
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 9 mois 3 semaines - il y a 8 mois 5 jours #11783 par placJCE
MediaBox sous JCE a été créé par placJCE
Bonjour Sarki, comme suggéré je poste mon pb sur le forum

J'utilise MediaBox dans JCE pour lier un article à afficher en popup lors du clic sur le lien
L'article s'ouvre bien dans une popup mais les images qu'il contient ne sont pas affichées et remplacées par le titre de l'image
Joomla 3.8.8
JCE 2.6.23

Cdlt,
Patrick
Dernière édition: il y a 8 mois 5 jours par mihaly. Raison: Ajout icône réglé

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 9 mois 3 semaines #11785 par mihaly
Réponse de mihaly sur le sujet MediaBox sous JCE
Hello Patrick,
Comme tu peux le voir sur les captures ci-dessous, tes images ont le nom d'un dossier qui s'ajoute à leur URL ce qui fait qu'elle ne s'afffichent pas, en supprimant le nom de ce dossier avec son / l'image apparait bien ;)

Mihàly Marti alias Sarki
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 9 mois 3 semaines #11786 par mihaly
Réponse de mihaly sur le sujet MediaBox sous JCE
Maintenant à savoir d'où vient le nom de ce dossier il peut y avoir différentes origines...
Sais-tu toi à quoi il correspond ?
C'est le nom du dossier de ton serveur dans lequel tu as déployé le site ?
As-tu fait des réglages particuliers par rapport au nouveau SEF de Joomla ?
Où as-tu changé le chemin du dossier "images" dans la configuration du profil JCE utilisé ou ailleurs ?
Si le fait de savoir que ce dossier s'ajoute à l'URL des images te met la puce à l'oreille, n'hésite pas à me mettre sur la piste ;)

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

  • placJCE
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 9 mois 3 semaines #11787 par placJCE
Réponse de placJCE sur le sujet MediaBox sous JCE
Merci mihaly
"popup-article" est l'alias du nom de la catégorie dans laquelle je regroupe les articles à afficher dans les popupMediabox mais je ne sais à quoi correspond le 8 devant ce nom
pas fait de réglage particulier. En fait je ne sais pas ce qu'est le SEF de Joomla
le dossier images est toujours celui d'origine de Joomla

A suivre ...
Patrick

Connexion ou Créer un compte pour participer à la conversation.

  • placJCE
  • Auteur du sujet
  • Hors Ligne
  • Nouveau Rédacteur
  • Nouveau Rédacteur
Plus d'informations
il y a 9 mois 3 semaines #11788 par placJCE
Réponse de placJCE sur le sujet MediaBox sous JCE
Je viens de faire un petit essai :
j'ai ajouté un lien de menu "articles" qui pointe vers ce même article"Sylvie-Patrick"
l'article est bien affiché avec ses images ET mystérieusement la popup contient AUSSI les images
si je dépublie le lien d'article (sans aucune autre modif) la popup est à nouveau KO sans les images
Si besoin d'infos complémentaires n'hésites pas

Patrick

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 9 mois 3 semaines #11789 par mihaly
Réponse de mihaly sur le sujet MediaBox sous JCE
Hello Patrick,
Ok, donc c'est bien un problème lié au SEF...
Le SEF est le système qui permet d'avoir des URLs en clair, car sinon elle correspondrait à la formule d'appel et de construction de la page qui se fait à l'aide de plusieurs bouts de page genre : "ton-site.com/index.php?option=com_content&view=article&id=1", alors qu'avec le SEF elle ressemblerait à une URL du genre : "ton-site.com/page1"

Joomla a implémenté un nouveau moteur SEF dans Joomla 3.8 ou 3.7 (je sais plus maintenant) qui peut poser des problèmes dans certains cas, mais ce ne devrait pas l'être avec JCE.

On voit que le nom de dossier qui s'ajoute est celui de la catégorie des articles, le chiffre 8 est certainement le no de la catégorie (toutes confondues, car tu as la catégorie par défaut des articles, mais tu aussi celle par défaut des contacts, des Flux RSS, etc. qui fait que même sur un Joomla neuf tu as déjà qqs catégories par défaut).
Il faut maintenant comprendre pourquoi cela s'ajoute à l'URL...

Il faut comprendre une chose, c'est que si tu n'as pas de lien de menu vers un article, celui-ci ne peut être affiché qu'en indiquant son no de catégorie et son no d'article. Cela est le cas par exemple si tu as un blog de plusieurs introductions d'article à la suite et que tu veux en afficher un en détail en cliquant sur son lien "Lire la suite" ; si aucun lien de menu n'existe vers cet article, l'URL affichera le no de sa catégorie et son no d'article.

Solution
Si tu vois qu'en créant un lien de menu vers l'article en question cela résoud le problème, je te conseillerai de faire ainsi :
1. Depuis la gestion des menus de Joomla, crée un nouveau menu mais que tu ne fais apparaitre dans aucun module, ce sera un menu fictif ;
2. Dans ce menu, crée un lien de menu vers la catégorie de tes articles qui pose problème et vérifie si tes popups s'affichent correctement... si oui alors c'est parfait :)

En effet tu ne dois pas avoir à faire un lien vers chaque article pour résoudre ce problème... Le fait de créer ce lien vers la catégorie va générer les URLs vers chaque article, comme ce ne sera plus à la popup de le faire, cela devrait résoudre le problème comme quand tu as testé en faisant un lien vers l'article ;)

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.197 secondes
Propulsé par Kunena

Rechercher