• Site mis à jour le 18 janvier 2019

Bugs, bugs, bugs, bugs....

  • jujusous3
  • Auteur du sujet
  • Hors Ligne
  • Rédacteur Occasionnel
  • Rédacteur Occasionnel
Plus d'informations
il y a 7 ans 8 mois #4902 par jujusous3
Bugs, bugs, bugs, bugs.... a été créé par jujusous3
Bonjour à tous,

Désolé pour le titre du sujet, mais c'est concrètement ce que je subit en ce moment :unsure:

Voilà par exemple deux bugs :

J'ai un bouton "Image" en bas de l'éditeur (qui n'a rien à voir avec JCE je pense mais peu importe), je l'utilise pour insérer mon image.

J'ai donc mon article, avec une image dedans, c'est tout.
Je clique sur l'image, je l'aligne à gauche, et bien, le curseur disparait, l'image bouge un peu vers le bas (petite espace blanc au dessus).
Si j'écris quelquechose, l'image est effacé par mon texte.

J'ai essayé avec TinyMCE, pas de problème.

J'ai réinstallé JCE (comp+plug), rien ne change.

Autre bug, si vous voulez mettre deux images côte à côte au centre d'un article, vous sélectionnez les deux articles, vous cliquer sur l'icône "centrer", et là BIM, les deux images s'affichent l'une en dessous de l'autre :dry:

Si quelqu'un pouvait tester chez lui, et si c'est un bug général...

Merci ;)

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 ans 8 mois #4904 par mihaly
Réponse de mihaly sur le sujet Bugs, bugs, bugs, bugs....
Hello,
Attention à ne pas confondre l'alignement effectué par une balise de container (div, p) et celui de l'image.
Par défaut, JCE ne donne pas d'alignement à une image, il faut le préciser manuellement si on le veut ou alors le mettre par défaut dans la configuration du plugin, dans le groupe JCE concerné.
L'intégration par le bouton sous l'éditeur est le plugin de Joomla, car TinyMCE proposé de base ne possède pas de gestionnaire de fichiers.
Il est donc déconseillé d'utiliser le bouton sous l'éditeur, perso je désactive ce plugin Joomla.

Pour centrer deux images, c'est le container qu'il faut aligner sans donner d'alignement aux images.
Commence par mettre une image, choisis dans la liste déroulante "Format" le paragraphe ou la balise div, puis centre ce container.
Clique à côté de l'image et insère la suivante. ;)

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

  • jujusous3
  • Auteur du sujet
  • Hors Ligne
  • Rédacteur Occasionnel
  • Rédacteur Occasionnel
Plus d'informations
il y a 7 ans 8 mois #4909 par jujusous3
Réponse de jujusous3 sur le sujet Bugs, bugs, bugs, bugs....
Merci pour ta réponse ;)

Je ne comprends pas bien, je ne veux pas que JCE mette un alignement par défaut sur mon image, là n'est pas la question.

Quand j'utilise le bouton Image de Joomla, je l'utilise uniquement pour insérer l'image dans l'article, rien d'autre.
Ensuite je clique sur l'image, j'ai un cadre noir autour avec des poignées, je peux la redimensionner "à la volée" avec la souris.
Ensuite, je clique sur l'image, et je clique sur l'icône d'alignement à gauche dans la barre d'outil JCE, et là : BIM, plus de curseur.

Je fais simplement un constat, avec MCE, je fais exactement la même chose, et je n'ai pas de problème.

Egalement, dans Wordpress, qui utilise plus ou moins le même type d'éditeur, je n'ai aucun bug, je clique sur l'image, je clique sur l'icône d'alignement à gauche, et hop l'image est à gauche et mon curseur en haut à droite de l'image.

Idem pour placer deux images côte à côte, normalement je devrais pouvoir insérer mes deux images, les sélectionner toutes les deux avec la souris, et cliquer sur l'icône d'alignement "centrer" pour les centrer... en tout cas sur Word press ça marche très bien...


J'espère que tu pourras m'aider, l'éditeur va être utilisé par des gens "lambda" donc si ça bug de partout ça va être impossible de lancer le site :/

Merci encore ;)


PS : J'ai un autre site de test, et sur celui-ci, je n'ai pas de "poignées" pour réduire l'image quand je la sélectionne dans l'éditeur, l'image est seulement surligné en bleu, comme quand tu sélectionne du texte. Et là, quand je la sélectionne, l'alignement à gauche ne pose pas de problème, le curseur est bien présent et est mis en haut à droite de l'image... Je ne vois pas ce que j'ai pu désactiver qui a pu causer cette différence au niveau de la sélection :/

Connexion ou Créer un compte pour participer à la conversation.

  • jujusous3
  • Auteur du sujet
  • Hors Ligne
  • Rédacteur Occasionnel
  • Rédacteur Occasionnel
Plus d'informations
il y a 7 ans 8 mois #4911 par jujusous3
Réponse de jujusous3 sur le sujet Bugs, bugs, bugs, bugs....
J'ai complètement désinstaller JCE (et pas seulement réinstaller par dessus), puis je l'ai installé de nouveau.

Ca a visiblement "réglé" le problème d'alignement à gauche où le curseur disparaissait.
Par contre, ça ne règle par le problème pour le centrage de deux images côte à côte.

Concrètement, dans WordPress, j'insérer deux images sans préciser l'alignement.
Je glisse ma souris en diagonale pour séléctionner mes deux images, je clique sur centrer dans la barre d'outil, et hop elles sont au milieu, centrées. Pourquoi ça devrait être plus compliqué sous Joomla alors que les deux éditeurs fonctionnent avec une base MCE identique ?

En fait, déjà, une différence entre les deux : WordPress "entoure" mes images par un bloc paragraphe (balise p et /p), même quand je ne tape rien, il crée déjà un bloc et tout ce que je taperai sera dedans.

Dans Joomla, JCE m'insérer mes deux images (balise img) directement, sans rien autour :
<img src="...."/><img src="...../>

Et si je clique sur centrer dans JCE, alors là c'est la catastrophe, il me crée des marges pour essayer d'aligner les images au centre tout ça, alors que c'est le bloc des deux images que je veux centrer...


Un autre BUG : j'ouvre l'éditeur, je clique sur centrer, le curseur reste à gauche, il ne se place pas au centre...

Merci encore

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 ans 8 mois #4930 par mihaly
Réponse de mihaly sur le sujet Bugs, bugs, bugs, bugs....
Arrête de parler de bug alors que ce n'est qu'un manque de connaissance et de réglage.
Si tu n'as pas de balise par défaut, div ou p, c'est que cet élément n'est pas ainsi réglé par défaut, c'est dans la configuration de JCE que tu peux le choisir.
Ensuite tout ce que tu dis changera car par défaut ce que tu insérera, texte ou image, sera dans un bloc de contenu.

Mihàly Marti alias Sarki

Connexion ou Créer un compte pour participer à la conversation.

  • jujusous3
  • Auteur du sujet
  • Hors Ligne
  • Rédacteur Occasionnel
  • Rédacteur Occasionnel
Plus d'informations
il y a 7 ans 8 mois - il y a 7 ans 8 mois #4935 par jujusous3
Réponse de jujusous3 sur le sujet Bugs, bugs, bugs, bugs....
Crois moi, je ne demande qu'à avoir tort ;)
Pour la config en effet on peut choisir de mettre une balise p ou div directement par défaut via les options.
Malheureusement, les balises <p> et </p> sont bien ajoutés autour de mes images, mais maintenant le problème se situe ailleurs : la sélection via la souris.

Je m'explique, si j'insère deux images, j'ai bien : <p><img ..../><img..../></p>, si je veux séléctionner le paragraphe entier, je place ma souris en bas de l'image droite je maintient le clic gauche et je fais glisser vers le coin gauche de l'image gauche (désolé pour les explications, faudrait que je fasse une vidéo).
Le problème c'est que cette sélection ne sélectionne qu'une ou les deux images (balises img) au lieu du paragraphe entier (balise p).
Du coup quand je clique sur centrer, les images se centrent l'une en dessous de l'autre :/


Par contre, si je fais ctrl+a (tout sélectionner), là ça prend bien mon paragraphe et mes images se centrent bien l'une à côté de l'autre. Mais cette astuce ne marchent que si je n'ai que les deux images dans mon texte (ctrl+a)...


T'as une astuce :/ Hésites pas à faire un screen ;)

Merci encore pour ton aide, ça serait super si ça pouvait marcher :)


Edit : Je viens de tester en rajoutant du texte de chaque côté de mes images, par exemple :

taratata....IMAGE1..IMAGE2...taratata

Là je peux plus facilement sélectionner le paragraphe entier avec la souris puisqu'il y a du texte, et ainsi je peux centrer mes images :) Mais je suis sur d'avoir testé ça sur le site en ligne cette aprem, et ça ne fonctionnait pas toujours bien.... Là je suis en local, donc je revérifierai demain et je te tiens au courant.


Aussi, j'ai testé la nouvelle version de JCE en beta, et de base, elle active l'option qui ajoute une balise p autour du contenu, je trouve ça plus logique c'est bien :) J'ai aussi beaucoup apprécié la sauvegarde automatique, malheureusement, j'utilise JCE avec K2, et l'ajout d'article se fait dans un pop-up, et dès la fermeture du pop-up après enregistrement j'ai une erreur :


"Cette page demande de confirmer sa fermeture; des données saisies pourraient ne pas être enregistrées"

ça serait du à la sauvegarde automatique de JCE ?
Dernière édition: il y a 7 ans 8 mois par jujusous3.

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.163 secondes
Propulsé par Kunena

Rechercher